zoukankan      html  css  js  c++  java
  • HDU-1013 Digital Roots

    Description

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

    Input

    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

    Output

    The output contains the number of digits in the factorial of the integers appearing in the input.

    Sample Input

    24

    39

    0

    Sample Output 

    6

    3


    九余数定理:一个数的数根等于该数除以9的余数。

    #include <iostream>
    using namespace std;
    
    int main(void)
    {
        char num[1000001];
        
        while(cin >> num && num[0] != '0')
        {
            long q = 0;
            int len = strlen(num);
            
            for(int i = 0; i < len; i++)
                q += (num[i]-'0');
            if(q%9 == 0)
                cout << 9 << endl;
            else
                cout << q%9 << endl;
        }
        
        return 0;
    }
    
  • 相关阅读:
    3、文件、函数练习题
    迭代器
    MySQL必知必会-用正则表达式进行搜索
    MySQL必知必会-检索数据
    数据结构与算法分析-树
    数据结构与算法分析-队列
    数据结构与算法分析-栈
    数据结构与算法分析-表
    数据结构与算法分析-算法分析
    数据结构与算法分析-引论
  • 原文地址:https://www.cnblogs.com/limyel/p/6679757.html
Copyright © 2011-2022 走看看