zoukankan      html  css  js  c++  java
  • POJ-1163 The Triangle

    Description

    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5

    (Figure 1)
    Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 
     

    Input

    Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99. 
     

    Output

    Your program is to write to standard output. The highest sum is written as an integer.
     

    Sample Input

    5
    7
    3 8
    8 1 0 
    2 7 4 4
    4 5 2 6 5

    Sample Output

    30

    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    using namespace std;
    
    int main(void)
    {
        int num[110][110], dp[110][110];
        int n;
        
        memset(dp, -1, sizeof(dp));
        cin >> n;
        for(int i = 0; i < n; i++)    {
            for(int j = 0; j <= i; j++)    {
                scanf("%d", &num[i][j]);
                if(i == n-1)
                    dp[i][j] = num[i][j];
            }
        }
        
        for(int i = n-2; i >= 0; i--)   {
            for(int j = 0; j <= i; j++)    {
                dp[i][j] = max(dp[i+1][j]+num[i][j], dp[i+1][j+1]+num[i][j]);
                
            }
        }
        
        cout << dp[0][0] << endl;
        
        return 0;
    }
    
  • 相关阅读:
    Django使用xadmin集成富文本编辑器Ueditor(方法二)
    Django-xadmin后台配置富文本编辑器(方法一)
    求解函数不等式[给定具体函数]
    区间断想
    函数方程和函数不等式
    对函数的再理解
    多题一解
    破解函数性质中的表达难点
    [数学模型]应用举例
    函数的迭代
  • 原文地址:https://www.cnblogs.com/limyel/p/7198641.html
Copyright © 2011-2022 走看看