zoukankan      html  css  js  c++  java
  • A1027 Colors in Mars (20)(20 分)

    A1027 Colors in Mars (20)(20 分)

    People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

    Input

    Each input file contains one test case which occupies a line containing the three decimal color values.

    Output

    For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

    Sample Input

    15 43 71
    

    Sample Output

    #123456
    

    思考

    给的数字范围是有限的168<(13^2)

    AC代码

    #include <stdio.h>
    char radix[13] = {
        '0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'A', 'B', 'C'
    };
    int main() {
        int r, g, b;
        scanf("%d%d%d", &r, &g, &b);
        printf("#");
        printf("%c%c", radix[r / 13], radix[r % 13]);
        printf("%c%c", radix[g / 13], radix[g % 13]);
        printf("%c%c", radix[b / 13], radix[b % 13]);
        return 0;
    }
    
  • 相关阅读:
    第六章学习小结
    malloc iOS
    iOS事件传递机制
    对 runloop 的理解
    深恶痛绝重写setter和getter
    数据库常见问题总结
    iOS多应用自动打包
    一段文字中包含多种语言时行间距问题
    一个成熟应用的排版方案
    Flask纪要
  • 原文地址:https://www.cnblogs.com/lingr7/p/9393261.html
Copyright © 2011-2022 走看看