zoukankan      html  css  js  c++  java
  • Fibonacci--poj3070(矩阵快速幂)

    http://poj.org/problem?id=3070

     

     

    Description

    In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

    0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

    An alternative formula for the Fibonacci sequence is

    .

    Given an integer n, your goal is to compute the last 4 digits of Fn.

    Input

    The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

    Output

    For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

    Sample Input

    0
    9
    999999999
    1000000000
    -1

    Sample Output

    0
    34
    626
    6875

    Hint

    As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

    .

    Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

    .

     

     

     

    这道题就是快速幂http://blog.csdn.net/u013795055/article/details/38599321

    还有矩阵相乘   

     

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <math.h>
    #include <stdlib.h>
    #include <vector>
    #include <queue>
    
    using namespace std;
    #define memset(a,b) memset(a,b,sizeof(a))
    #define N 4
    #define INF 0xfffffff
    struct node
    {
        int a[N][N];
    }e;
    
    node mm(node p,node q)
    {
        node t;
        for(int i=0;i<2;i++)
        {
            for(int j=0;j<2;j++)
            {
                t.a[i][j]=0;
                for(int k=0;k<2;k++)
                {
                    t.a[i][j]=(t.a[i][j]+(p.a[i][k]*q.a[k][j]))%10000;
                }
            }
        }
        return t;
    }
    
    
    node mul(node p,int n)
    {
    
        node q;
        for(int i=0;i<2;i++)
        {
            for(int j=0;j<2;j++)
            {
                q.a[i][j]=(i==j);
            }
        }///这个是为了当n是奇数是第一次跟q相乘是还是原来的p,为了下一次跟下一奇数相乘
    while(n) { if(n&1) q=mm(q,p); n=n/2; p=mm(p,p); } return q; } int main() { int n; while(scanf("%d",&n),n!=-1) { e.a[0][0]=1; e.a[0][1]=1; e.a[1][0]=1; e.a[1][1]=0; node b=mul(e,n); printf("%d ",b.a[0][1]); } return 0; }
  • 相关阅读:
    CentOS7修改网卡为eth0
    前端开发实时可视化
    push本地代码到github发生错误的解决办法
    前端面试总结(一)
    HTML5+CSS3开发移动端页面
    web安全-XSS
    前端面试总结
    JavaScript中的原型和原型链
    jQuery与Ajax
    JavaScript中模块化工具require.js
  • 原文地址:https://www.cnblogs.com/linliu/p/5280359.html
Copyright © 2011-2022 走看看