zoukankan      html  css  js  c++  java
  • pat 甲级 1045 ( Favorite Color Stripe ) (动态规划 )

    1045 Favorite Color Stripe (30 分)

    Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

    It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

    Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10​4​​) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

    Output Specification:

    For each test case, simply print in a line the maximum length of Eva's favorite stripe.

    Sample Input:

    6
    5 2 3 1 5 6
    12 2 2 4 1 5 5 6 3 1 1 5 6
    

    Sample Output:

    7

    思路:设dp[i][j]为考虑从第0到i种颜色,考虑到长度从0到第j时的最长结果,那么状态转移方程是显而易见的。

    代码如下:

    #include<bits/stdc++.h>
    using namespace std;
    int n,m,l;
    int color[205];
    int a[10004];
    int dp[205][10005];
    int main()
    {
        cin>>n;
        cin>>m;
        for(int i=0;i<m;i++)cin>>color[i];
        cin>>l;
        for(int i=0;i<l;i++)cin>>a[i];
        dp[0][0]=(color[0]==a[0])?1:0;
        for(int j=1;j<l;j++)dp[0][j]=(color[0]==a[j])?dp[0][j-1]+1:dp[0][j-1];
        for(int i=1;i<m;i++)dp[i][0]=(color[i]==a[0])?1:dp[i-1][0];
        for(int i=1;i<m;i++)
        {
            for(int j=1;j<l;j++)
            {
                if(color[i]==a[j])dp[i][j]=max(dp[i-1][j],dp[i][j-1]+1);
                else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
        }
        cout<<dp[m-1][l-1]<<endl;
        return 0;
    }
    
  • 相关阅读:
    安装oracle 使用vnc无法打开terminal,解决办法
    linux服务器配置本地yum仓库
    less css 框架介绍
    html的概念
    html
    WEB前端第三十八课——js类和对象,继承,设计模式
    WEB前端第三十七课——jsBOM操作-DataParse、jsEngine、性能、history、道岔、closure
    WEB前端第三十六课——jsBOM操作-window、timer
    WEB前端第三十五课——事件绑定应用案例
    WEB前端第三十四课——js事件对象this、event
  • 原文地址:https://www.cnblogs.com/linruier/p/10085405.html
Copyright © 2011-2022 走看看