zoukankan      html  css  js  c++  java
  • POJ 2456 编程技巧之------二分查找思想的巧妙应用

    Aggressive cows
    Time Limit: 1000MS Memory Limit: 65536K
    Total Submissions: 18599 Accepted: 8841

    Description

    Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

    His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

    Input

    * Line 1: Two space-separated integers: N and C 

    * Lines 2..N+1: Line i+1 contains an integer stall location, xi

    Output

    * Line 1: One integer: the largest minimum distance

    Sample Input

    5 3
    1
    2
    8
    4
    9

    Sample Output

    3


    #include<stdio.h>
    #include<algorithm>
    #include<math.h>
    using namespace std;
    #define INF 999999999
    const int MAX_N=100005;
    int N,M;
    int x[MAX_N];


    //判断是否满足条件
    bool C(int d)
    {
        int last=0;
        for(int i=1;i<M;i++)
        {
            int crt=last+1;
            while(crt<N&&x[crt]-x[last]<d)
            {
                crt++;
            }
            if(crt==N)return false;
            last = crt;
        }
        return true;
    }
    void solve()
    {
        sort(x,x+N);
        int lb=0,ub=INF;
        int mid;
        while(ub-lb>1)
        {
            mid=(lb+ub)/2;
            if(C(mid))lb=mid;
            else ub=mid;
        }
        printf("%d ",lb);
    }


    int main()
    {
        //freopen("C://Users/Administrator/Desktop/acm.txt","r",stdin);
        scanf("%d%d",&N,&M);
        for(int i=0;i<N;i++)
        {
            scanf("%d",&x[i]);
        }
        solve();
        return 0;
    }



  • 相关阅读:
    10.用户管理
    9.更新系统时间
    8.标准输入输出重定向
    7.文件压缩与find命令
    6.Linux文件的详细属性
    5.Linux基础命令
    4.Linux目录结构
    3.磁盘光驱挂载
    2.xshell连接
    javascript中的location的用法
  • 原文地址:https://www.cnblogs.com/linruier/p/9485188.html
Copyright © 2011-2022 走看看