zoukankan      html  css  js  c++  java
  • A Knight's Journey (DFS)

    题目:

    Background
    The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
    around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

    Problem
    Find a path such that the knight visits every square once. The knight can start and end on any square of the board.Input

    The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
    If no such path exist, you should output impossible on a single line.

    Sample Input

    3
    1 1
    2 3
    4 3

    Sample Output

    Scenario #1:
    A1
    
    Scenario #2:
    impossible
    
    Scenario #3:
    A1B3C1A2B4C2A3B1C3A4B2C4

    题意:
    给你一个p*q的棋盘,跳马在上面的任意一格开始移动,只能走‘日’字,问你能不能经过棋盘上面所有的格子;(百度的题意,明明是说经过所有的格子,有道硬是翻译
    成了“
    找到一条这样的路,骑士每一次都要去一次”),输出要按照字典顺序输出

    分析:
    深度优先搜索,要经过所有的格子,那就肯定经过(1,1),所以就可以从(1,1)开始搜索;

    AC代码:
    
    

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    using namespace std;
    int t,p,q,flag;
    int a[30][30];
    int step[30][30];
    int f[8][2]={{1,-2},{-1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
    void dfs(int x,int y,int z)
    {
        step[z][1]=x;
        step[z][2]=y;
         if (z==p*q)
         {
                flag=1;
                return ;
         }

    
    

        for (int i=0;i<8;i++)
            {
                int xi=x+f[i][0];
                int yi=y+f[i][1];
                if (xi>=1&&xi<=p&&yi>=1&&yi<=q&&!a[xi][yi]&&!flag)
                {
                    a[xi][yi]=1;
                    dfs(xi,yi,z+1);
                    a[xi][yi]=0;
                }
            }

    
    

    }
    int main()
    {
        cin>>t;
       for (int i=1;i<=t;i++)
        {
            flag=0;
           scanf("%d%d",&p,&q);
            memset(a,0,sizeof(a));
            memset(step,0,sizeof(step));
            a[1][1]=1;
            dfs(1,1,1);
            printf("Scenario #%d: ",i);
            if (flag==1)
             {
                 for (int j=1;j<=p*q;j++)
               printf("%c%d",step[j][2]+'A'-1,step[j][1]);
                 printf(" ");
             }
            else
                printf("impossible ");
            if (i!=t)
                printf(" ");
        }
        return 0;
    }

    
    
     


  • 相关阅读:
    B站开源播放框架ijkplayer(iOS版)使用教程
    GitHub前50名的Objective-C动画相关库
    iOS系统自带的 UIAlertView 自动旋转的实现
    iOSAPP启动时实现加载广告
    每周分享第5期(2019.5.4)
    如何为Redis中list中的项设置过期时间
    对scrapy进行单元测试 -- 使用betamax
    【AMAD】betamax -- 一个ruby-VCR的模仿品,只支持requests
    【AMAD】stackprint -- 为Python加入利于调试的traceback信息
    【AMAD】Pysnooper -- 别再用print进行debug了
  • 原文地址:https://www.cnblogs.com/lisijie/p/7243871.html
Copyright © 2011-2022 走看看