zoukankan      html  css  js  c++  java
  • The Suspects

    题目:

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
    Once a member in a group is a suspect, all members in the group are suspects. 
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1

    题意:
    有n个人,m个团体,当中有一个人有传染病(题意假设为编号为0的人有传染病),那么他所在的组织里面的人就会被传染,
    你的人去就是求有多少个人有传染病!!!

    分析:
    考察的就是并查集的运用,将一个组织的人并在一起,最后求和0并在一个集合里面的人数;

    AC代码:
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    const int N = 30005;
    int father[N],Rank[N];
    int a[N];
    int num[N];  //num数组用于存储与某个人在一个团体中的人数
    int Find (int x)  //查找
    {
        while (father[x]!=x)
        {
              x=father[x];
        }
    
        return x;
    }
    void Union(int x, int y)  //合并,将在一个团体中的两个人合并到一个集合
    {
        x = Find(x);
        y = Find(y);
        if(x == y)return ;
        else
        {
           father[y] = x;
            num[x]+= num[y];   //扩大团体
        }
    }
    int main()
    {
        int n,m,total,flag;
        while (cin>>n>>m&&(n!=0||m!=0))
        {
            for (int i=0;i<n;i++)
             {
                  father[i]=i;
                  num[i]=1;
             }
    
            while (m--)
            {
                cin>>total;
                if (total!=0)
                    cin>>a[0];
                for (int i=1;i<total;i++)
                  {
                       cin>>a[i];
                       Union(a[i],a[i-1]);
                  }
            }
        cout << num[Find(0)] << endl;
        }
        return 0;
    }
     
  • 相关阅读:
    UVM系统验证基础知识0(Questasim搭建第一个UVM环境)
    DDR3详解(以Micron MT41J128M8 1Gb DDR3 SDRAM为例)
    正则表达式的基本用法
    Veloce2 Emulator
    Perl入门
    哪一种验证方法最好?形式验证、硬件加速还是动态仿真?
    什么是形式验证?
    穆里尼奥之皮洛斯式胜利
    穆帅:孟菲斯是计划中重要的一部分
    CentOS Netstat命令
  • 原文地址:https://www.cnblogs.com/lisijie/p/7295906.html
Copyright © 2011-2022 走看看