zoukankan      html  css  js  c++  java
  • Let the Balloon Rise

    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 61357    Accepted Submission(s): 22597


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you. 
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5 green red blue red red 3 pink orange pink 0
     
    Sample Output
    red pink
    #include<iostream>
    #include<string>
    #include<map>
    using namespace std;
    
    int main()
    {
    	int T,i,max;
    	string s,ans;
    
    	while(cin>>T,T)
    	{
    		map<string,int>mp;
    		max=-1;
    		for(i=0;i<T;i++)
    		{
    			cin>>s;
    			mp[s]++;
    			if(mp[s]>max){max=mp[s];ans=s;}
    		}
    		cout<<ans<<endl;
    	}
    	return 0;
    }
    

      

    世上无难事,只要肯登攀。
  • 相关阅读:
    【BZOJ4472】salesman(树形DP)
    【CF314C】Sereja and Subsequences(DP,树状数组)
    KMP模板
    【vijos1144】小胖守皇宫(树形DP)
    【CF696B】Puzzles(树形DP,期望)
    纪录一个table元素里面的tr th td
    css动态样式
    动态脚本,在js里面又写js
    DOM---documentFragment
    DOM----comment类型
  • 原文地址:https://www.cnblogs.com/littlehoom/p/3427078.html
Copyright © 2011-2022 走看看