zoukankan      html  css  js  c++  java
  • POJ3253(贪心)

    Fence Repair
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 22196   Accepted: 7074

    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
     
    大意:把一根棍子截成n段,每截出两段所需的花费是这两段之和,求最少花费。
    这个的思路就跟哈夫曼编码一样,所求就是所有父节点之和。为什么呢?
    因为n段要截n-1次,每次都要花费最小,即父节点最小,那么就相当于哈夫曼了。比如1、2、3、4、5,要截成这5段,你画一画再思考一下是不是这个道理。
    #include<iostream>
    #include<cstdio>
    #include<queue>
    #include<algorithm>
    using namespace std;
    struct node{
        int len, flag;
        friend bool operator <(node a, node b){
            return a.len > b.len;//没必要弄个结构体,之所以弄了是因为我开始时没考虑清楚,,,这个a.len>b.len代表的是len越小优先级越高,嘿嘿,困惑吧,那就去补一下呗
        }                        //http://www.cnblogs.com/littlehoom/p/3550469.html
    };
    priority_queue<node>que;
    int main()
    {
        int n, len, Len=0,t1,t2;
        __int64 sum = 0;
        node a;
        cin >> n;
        for (int i = 0; i < n; i++){
            cin >> len;
            Len += len;
            a.len = len;
            a.flag = 0;
            que.push(a);
        }
        while (Len != que.top().len){
            t1 = que.top().len; que.pop();
            t2 = que.top().len; que.pop();
            a.len = t1 + t2;
            que.push(a);
            sum += a.len;
        }
        cout << sum << endl;
        return 0;
    }
    世上无难事,只要肯登攀。
  • 相关阅读:
    (13)使用Ajax Helper 提高用户体验
    (12)改变图片的大小生成缩略图
    (11)通过表单上传文件
    程序员需要有多懒 ?- cocos2d-x 数学函数、常用宏粗整理
    xCode 4.X 免证书真机发布及调试
    35岁前必须做好的10件事情(转载)
    独自收集Cocos2d提供的字体!共57种(有对照的字体图)
    (10)根据关键字搜索
    tcp拥塞控制
    dpcnv reademe
  • 原文地址:https://www.cnblogs.com/littlehoom/p/3550436.html
Copyright © 2011-2022 走看看