zoukankan      html  css  js  c++  java
  • POJ练习深搜

    Red and Black
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 20512   Accepted: 10986

    Description

    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

    Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

    Input

    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

    '.' - a black tile 
    '#' - a red tile 
    '@' - a man on a black tile(appears exactly once in a data set) 
    The end of the input is indicated by a line consisting of two zeros. 

    Output

    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

    Sample Input

    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0

    Sample Output

    45
    59
    6
    13
    #define _CRT_SECURE_NO_DEPRECATE
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #define MAX 30
    using namespace std;
    char g[MAX][MAX];
    int n, m, bx, by, totle;//行、列,起始坐标,总结果
    int dx[4] = { -1, 1, 0, 0 }, dy[4] = { 0, 0, 1, -1 };
    void dfs(int x, int y){
        g[x][y] = '#';
        for (int i = 0; i < 4; i++){
            int tx = x + dx[i], ty = y + dy[i];
            if (0 <= tx&&tx < n && 0 <= ty&&ty < m&&g[tx][ty] == '.'){//0<= tx, 不要写成0<tx
                totle++;
                dfs(tx, ty);
            }
        }
    }
    int main()
    {
        while (true){
            cin >> m >> n;
            if (m + n == 0)break;
            for (int i = 0; i < n; i++){
                for (int j = 0; j < m; j++){
                    cin >> g[i][j];
                    if (g[i][j] == '@'){
                        bx = i;
                        by = j;
                    }
                }
            }
            totle = 1;
            dfs(bx, by);
            cout << totle << endl;
        }
        return 0;
    }
    世上无难事,只要肯登攀。
  • 相关阅读:
    (六)知识蒸馏
    tensorflow(三十一):数据分割与K折交叉验证
    📚面试题 1 (46题)
    🍖drf 路由组件
    🍖drf 视图组件
    🍖drf 请求与响应
    🍖drf 序列化组件
    🍖DRF框架入门介绍
    如何在大学里脱颖而出(其一)
    reshape()改变数组的形状
  • 原文地址:https://www.cnblogs.com/littlehoom/p/3556643.html
Copyright © 2011-2022 走看看