zoukankan      html  css  js  c++  java
  • 优先队列啦-POJ3253

    ence Repair
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 28008   Accepted: 9098

    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34
    //#define _CRT_SECURE_NO_DEPRECATE
    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<queue>
    #include<functional>
    #include<algorithm>
    using namespace std;
    
    struct node{
        long long weight;
        struct node *lc, *rc;
        node(){
            weight = 0;
            lc = rc = NULL;
        }
        friend bool operator<(node x, node y){
            return x.weight > y.weight;        //值越小越靠前(不要纠结不要纠结^o^)
        }
    };
    
    void solve(){
        priority_queue<node> que;
        int n;
        long long res = 0;
        cin >> n;
        for (int i = 0; i < n;i++){
            node t;
            cin >> t.weight;
            que.push(t);
        }
        while (n>1){
            node td;
            td.weight = que.top().weight; que.pop();
            td.weight += que.top().weight; que.pop();
            res += td.weight;
            que.push(td);
            n--;
        }
        cout << res << endl;
    }
    
    int main()
    {
        solve();
        //system("pause");
        return 0;
    }
    世上无难事,只要肯登攀。
  • 相关阅读:
    linux 中mysql的安装过程
    HashMap和Hashtable的区别
    SVN服务器配置(svn1.4.6+apache2.2.8 no ssl)
    ArrayList Vector LinkedList 区别与用法
    java中equals和==的区别
    flash滤镜
    AS3显示对象
    feathers ui 鼠标移出事件
    Flex 中可以应用于 ActionScript 类的元标签
    pureMVC与RobotLegs actionscript MVC框架对比
  • 原文地址:https://www.cnblogs.com/littlehoom/p/4198841.html
Copyright © 2011-2022 走看看