zoukankan      html  css  js  c++  java
  • 数据结构课后练习题(练习一)1007 Maximum Subsequence Sum (25 分)

    Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    

    Sample Output:

    10 1 4

    初始一个错误点的代码:
    #include <iostream>
    using namespace std;
    int main()
    {
        int N;
        cin>>N;
        int a[N];
        int sum=0,sumMax=-1,startPoint=0,tempPoint=0,endPoint=N-1;
        //sum 和 sumMax最大数 tempPoint记录临时指针
        for(int i=0;i<N;i++){
            cin>>a[i];
            sum+=a[i];
            if(sum<0){
                sum=0;
                tempPoint=i;
            }else if(sum>sumMax){
                sumMax=sum;
                startPoint=tempPoint+1;
                endPoint=i;
            }
        }
        if(sumMax<0)sumMax=0;//应该注意如果没有一个为0,那么应该输出0,首项,末项
        cout<<sumMax<<" "<<a[startPoint]<<" "<<a[endPoint];
        return 0;
    }

    验证了很久,发现是第i个有错,一定要注意,tempPoint不能在startPoint处+1,理由:首次为0会计数为1,而在sum<0的条件下去计数,则会,首次小于0,将startPoint进行重置为后一个数字,这个错误提醒自己,每个程式都要进行测试用例的猜测。

    #include <iostream>
    using namespace std;
    int main()
    {
        int N;
        cin>>N;
        int a[N];
        int sum=0,sumMax=-1,startPoint=0,tempPoint=0,endPoint=N-1;
        //sum 和 sumMax最大数 tempPoint记录临时指针
        for(int i=0;i<N;i++){
            cin>>a[i];
            sum+=a[i];
            if(sum<0){
                sum=0;
                tempPoint=i+1;
            }else if(sum>sumMax){
                sumMax=sum;
                startPoint=tempPoint;
                endPoint=i;
            }
        }
        if(sumMax<0)sumMax=0;//应该注意如果没有一个为0,那么应该输出0,首项,末项
        cout<<sumMax<<" "<<a[startPoint]<<" "<<a[endPoint];
        return 0;
    }
     
  • 相关阅读:
    VS2019删除大量空白行或者缩进大量空白行
    VS219 没有.net core 3.0模板
    Win10怎么添加开机启动项?Win10添加开机自动运行软件三种方法
    Unity 屏幕坐标到UGUI RectTransform本地坐标的转换
    MySQL 常用帮助信息
    CentOS 7 系统初始化
    JDK 安装部署
    centos7 yum install redis
    Redis5.0.3单机版安装
    shell 脚本检测端口状态
  • 原文地址:https://www.cnblogs.com/littlepage/p/11227246.html
Copyright © 2011-2022 走看看