zoukankan      html  css  js  c++  java
  • PAT Advanced 1042 Shuffling Machine (20 分)(知识点:利用sstream进行转换int和string)

    Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

    The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

    S1, S2, ..., S13, 
    H1, H2, ..., H13, 
    C1, C2, ..., C13, 
    D1, D2, ..., D13, 
    J1, J2
    

    where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer K (≤) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    2
    36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
    

    Sample Output:

    S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5


    #include <iostream>
    #include <sstream>
    using namespace std;
    
    int main()
    {
        //initial
        string card[54];
        stringstream sstemp;
        string shuffle[54];
        for(int i=1;i<=13;i++){
            card[i-1]="S";
            sstemp<<i;
            card[i-1]+=sstemp.str();
            sstemp.str("");
            //注意sstream进行清空只能sstream.str("")
            //目前已经没有atoi了,同样字符串转换int也可以使用stringsteam
        }
        for(int i=1;i<=13;i++){
            card[i+13-1]="H";
            sstemp<<i;
            card[i+13-1]+=sstemp.str();
            sstemp.str("");
        }
        for(int i=1;i<=13;i++){
            card[i+13*2-1]="C";
            sstemp<<i;
            card[i+13*2-1]+=sstemp.str();
            sstemp.str("");
        }
        for(int i=1;i<=13;i++){
            card[i+13*3-1]="D";
            sstemp<<i;
            card[i+13*3-1]+=sstemp.str();
            sstemp.str("");
        }
        card[52]="J1";card[53]="J2";
        //读入数据
        int count;//洗牌次数
        cin>>count;
        int a[54];
        for(int i=0;i<54;i++){
            cin>>a[i];
        }
        while(count--){
            //洗牌
            for(int i=0;i<54;i++){
                shuffle[a[i]-1]=card[i];
            }
            for(int i=0;i<54;i++){
                card[i]=shuffle[i];
            }
        }
        for(int i=0;i<53;i++){
            cout<<card[i]<<" ";
        }
        cout<<card[53];
        /*
        读题:自动洗牌
        54张牌
        1-54如s1-J2
        把index位置的牌放在order[index]位置
        */
        system("pause");
        return 0;
    }

    总结:atoi和itoa函数已经没有了,如果进行string与int的转换,可以利用c++的sstring中的stringstream

    stringstream s;
    
    string a;int b;
    
    s<<a;s>>b;
    
    s<<b;s>>a;

    string和int可以互相流入流出

  • 相关阅读:
    一天一个设计模式(15)——中介者模式
    一天一个设计模式(14)——迭代器模式
    一天一个设计模式(13)——命令模式
    一天一个设计模式(12)——责任链模式
    一天一个设计模式(11)——代理模式
    《windows程序设计》学习_3.4:实现雷区翻转
    《windows程序设计》学习_3.3:利用xp扫雷资源
    《windows程序设计》学习_3.2:左键的使用
    《windows程序设计》学习_3.1:画出雷区,左键的使用
    《windows程序设计》学习_2.2:初识消息,双键的使用
  • 原文地址:https://www.cnblogs.com/littlepage/p/11273778.html
Copyright © 2011-2022 走看看