zoukankan      html  css  js  c++  java
  • PAT Advanced 1041 Be Unique (20 分)

    Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

    Input Specification:

    Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤) and then followed by N bets. The numbers are separated by a space.

    Output Specification:

    For each test case, print the winning number in a line. If there is no winner, print None instead.

    Sample Input 1:

    7 5 31 5 88 67 88 17
    

    Sample Output 1:

    31
    

    Sample Input 2:

    5 888 666 666 888 888
    

    Sample Output 2:

    None
    #include <iostream>
    using namespace std;
    int main(){
        int T;
        cin>>T;
        int va[T],coun[10001];
        for(int i=0;i<T;i++){
            scanf("%d",&va[i]);
            coun[va[i]]++;
        }
        bool has=false;
        for(int i=0;i<T;i++){
            if(coun[va[i]]==1) {
                cout<<va[i];
                has=true;
                break;
            }
        }
        if(!has) cout<<"None";
        system("pause");
        return 0;
    }
  • 相关阅读:
    python全局变量与局部变量
    TCP的三次握手四次挥手
    关于Http的面试题
    HSTS
    关于网络安全攻防知识
    http详解
    python中的f''、b''、u''、r''
    常见SQL Server导入导出数据的几个工具
    chrome浏览器中 F12 功能的简单介绍
    Sqlcmd使用详解
  • 原文地址:https://www.cnblogs.com/littlepage/p/11355648.html
Copyright © 2011-2022 走看看