zoukankan      html  css  js  c++  java
  • PAT Advanced 1071 Speech Patterns (25 分)

    People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

    Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

    Input Specification:

    Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return  . The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

    Output Specification:

    For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

    Note that words are case insensitive.

    Sample Input:

    Can1: "Can a can can a can?  It can!"
    

    Sample Output:

    can 5

    切记,在遍历的时候,要把最后一个数值加上去

    #include <iostream>
    #include <unordered_map>
    using namespace std;
    int main()
    {
        unordered_map<string,int> mmap;
        string str;
        getline(cin,str);
        string tmp="";
        for(int i=0;i<str.length();i++) {
            str[i]=tolower(str[i]);
            if(isalnum(str[i])) tmp+=str[i];
            else {
                if(tmp!="") mmap[tmp]++;
                tmp="";
            }
        }
        if(tmp!="") mmap[tmp]++;
        string res;int coun=0;
        for(auto it=mmap.begin();it!=mmap.end();it++)
            if(it->second>coun){
                coun=it->second;
                res=it->first;
            }
        cout<<res<<" "<<coun;
        return 0;
    }
  • 相关阅读:
    wpf 不规则窗体
    wpf treeview使用expanded事件出错的问题
    获取文件图标
    C#操作快捷方式总结
    mysql 更改存储引擎,更改自增列计数值,更改默认字符集
    zend framework集成smarty
    文本文件数据导入mysql注意事项
    MYSQL 外键
    uchome 日志发布函数blog_post()
    mysql order by null
  • 原文地址:https://www.cnblogs.com/littlepage/p/11804872.html
Copyright © 2011-2022 走看看