zoukankan      html  css  js  c++  java
  • PAT Advanced 1071 Speech Patterns (25 分)

    People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

    Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

    Input Specification:

    Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return  . The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

    Output Specification:

    For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

    Note that words are case insensitive.

    Sample Input:

    Can1: "Can a can can a can?  It can!"
    

    Sample Output:

    can 5

    切记,在遍历的时候,要把最后一个数值加上去

    #include <iostream>
    #include <unordered_map>
    using namespace std;
    int main()
    {
        unordered_map<string,int> mmap;
        string str;
        getline(cin,str);
        string tmp="";
        for(int i=0;i<str.length();i++) {
            str[i]=tolower(str[i]);
            if(isalnum(str[i])) tmp+=str[i];
            else {
                if(tmp!="") mmap[tmp]++;
                tmp="";
            }
        }
        if(tmp!="") mmap[tmp]++;
        string res;int coun=0;
        for(auto it=mmap.begin();it!=mmap.end();it++)
            if(it->second>coun){
                coun=it->second;
                res=it->first;
            }
        cout<<res<<" "<<coun;
        return 0;
    }
  • 相关阅读:
    ubuntu14.4开启ftp服务
    ubuntu14.4安装gtx970显卡驱动的艰辛历程
    jquery.dataTables的用法
    win7上安装theano keras深度学习框架
    使用BeanUtils设置属性转换String到Date类型
    keras在win7下环境搭建
    Python-try except else finally有return时执行顺序探究
    MySQL-EXPLAIN用法详解
    PHP-Windows下搭建Nginx+PHP环境
    PHP-php.ini中文版
  • 原文地址:https://www.cnblogs.com/littlepage/p/11804872.html
Copyright © 2011-2022 走看看