zoukankan      html  css  js  c++  java
  • PAT Advanced 1071 Speech Patterns (25分)

    People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

    Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

    Input Specification:

    Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return  . The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

    Output Specification:

    For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

    Note that words are case insensitive.

    Sample Input:

    Can1: "Can a can can a can?  It can!"
    
     

    Sample Output:

    can 5

    这题用头索引和尾索引进行扫描
    如果whie尾索引不是字母和数字,尾指针++
    然后进行截取字符串(同时进行判断是否是大于最大的,resKey和resValue记录最大的key和最大的value)
    while不是字母和数字,进行尾索引++,为了过滤连续的特殊字符
    然后使start = _end
    最后打印即可
    #include <iostream>
    #include <string>
    #include <unordered_map>
    using namespace std;
    int main(){
        string str, resKey;
        int resValue;
        unordered_map<string, int> m;
        getline(cin, str);
        for(int i = 0; i < str.length(); i++)
            str[i] = tolower(str[i]);//转换小写字母
        int start = 0;
        for(int _end = 0; _end < str.length(); _end++) {
            string tmp = "";
            while(isalnum(str[_end])) _end++;
            if(++m[str.substr(start, _end - start)] > resValue){
                resKey = str.substr(start, _end - start);
                resValue = m[resKey];
            }
            while(!isalnum(str[_end])) _end++;
            start = _end;
        }
        cout << resKey << " " <<resValue;
        return 0;
    }
  • 相关阅读:
    HDU5087——Revenge of LIS II(BestCoder Round #16)
    HDU5086——Revenge of Segment Tree(BestCoder Round #16)
    POJ3009——Curling 2.0(DFS)
    POJ2891——Strange Way to Express Integers(模线性方程组)
    算法总结之求解模线性方程组
    Linux运维学习笔记-网络技术知识体系总结
    Linux运维学习笔记-定时任务知识总结
    Linux运维学习笔记-文件权限知识总结
    Linux运维学习笔记-常用快捷键及vi、vim总结
    Linux运维学习笔记-角色知识总结
  • 原文地址:https://www.cnblogs.com/littlepage/p/12232875.html
Copyright © 2011-2022 走看看