zoukankan      html  css  js  c++  java
  • PAT Advanced 1022 Digital Library (30分)

    A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

    • Line #1: the 7-digit ID number;
    • Line #2: the book title -- a string of no more than 80 characters;
    • Line #3: the author -- a string of no more than 80 characters;
    • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
    • Line #5: the publisher -- a string of no more than 80 characters;
    • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

    It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

    After the book information, there is a line containing a positive integer M (≤) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

    • 1: a book title
    • 2: name of an author
    • 3: a key word
    • 4: name of a publisher
    • 5: a 4-digit number representing the year

    Output Specification:

    For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

    Sample Input:

    3
    1111111
    The Testing Book
    Yue Chen
    test code debug sort keywords
    ZUCS Print
    2011
    3333333
    Another Testing Book
    Yue Chen
    test code sort keywords
    ZUCS Print2
    2012
    2222222
    The Testing Book
    CYLL
    keywords debug book
    ZUCS Print2
    2011
    6
    1: The Testing Book
    2: Yue Chen
    3: keywords
    4: ZUCS Print
    5: 2011
    3: blablabla
    
     

    Sample Output:

    1: The Testing Book
    1111111
    2222222
    2: Yue Chen
    1111111
    3333333
    3: keywords
    1111111
    2222222
    3333333
    4: ZUCS Print
    1111111
    5: 2011
    1111111
    2222222
    3: blablabla
    Not Found
    
     

    这题考了哈希映射,我们在进行读取的时候,顺便给了一次哈希映射,

    然后哈希映射中嵌套了一个map,map是一个有序的哈希映射,保证有序。

    那么查找的效率为O(1)

    #include <iostream>
    #include <vector>
    #include <unordered_map>
    #include <map>
    #include <sstream>
    using namespace std;
    int main(){
        int N, M;
        cin >> N;
        string id, title, author, kw, publisher, year, search_s;
        getline(cin, search_s);
        unordered_map<string, map<string, string>> m;
        while(N--) {
            getline(cin,id);
            getline(cin,title);
            getline(cin,author);
            getline(cin,kw);
            getline(cin,publisher);
            getline(cin,year);
            m[title][id] = id;
            m[author][id] = id;
            stringstream ss;
            ss << kw;
            while(ss >> kw) m[kw][id] = id;
            m[publisher][id] = id;
            m[year][id] = id;
        }
        cin >> M;
        getline(cin, search_s);
        while(M--) {
            getline(cin, search_s);
            cout << search_s << endl;
            search_s = search_s.substr(3);
            if(m[search_s].size() == 0)
                cout << "Not Found" <<endl;
            else {
                for(auto x: m[search_s])
                    cout << x.second << endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    kafka 生产者消费者 api接口
    湖南省第九届大学生计算机程序设计竞赛 Interesting Calculator
    Debugger DataSet 调试时查看DataSet
    DELPHI 常用虚拟键:VK_
    DBGRID控件里可以实现SHIFT复选吗?怎么设置?
    在dbgrid中如何多行选中记录(ctl与shift均可用)
    如何在DBGrid里实现Shift+“选择行”区间多选的功能!
    按着shift键对dbgrid进行多条记录选择的问题(50分)
    Delphi实现DBGrid Shift+鼠标左键单击 多选
    Delphi定位TDataSet数据集最后一条记录
  • 原文地址:https://www.cnblogs.com/littlepage/p/12235799.html
Copyright © 2011-2022 走看看