zoukankan      html  css  js  c++  java
  • PAT Advanced 1025 PAT Ranking (25分)

    Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive number N (≤), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

    registration_number final_rank location_number local_rank
    
     

    The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

    Sample Input:

    2
    5
    1234567890001 95
    1234567890005 100
    1234567890003 95
    1234567890002 77
    1234567890004 85
    4
    1234567890013 65
    1234567890011 25
    1234567890014 100
    1234567890012 85
    
     

    Sample Output:

    9
    1234567890005 1 1 1
    1234567890014 1 2 1
    1234567890001 3 1 2
    1234567890003 3 1 2
    1234567890004 5 1 4
    1234567890012 5 2 2
    1234567890002 7 1 5
    1234567890013 8 2 3
    1234567890011 9 2 4

    这题主要考了排序。

    我们用一个嵌套vector进行存储,分别把vector进行排序,之后赋值排名。

    之后集合在一个总vector,进行排序,进行赋值排名即可。

    #include <iostream>
    #include <vector>
    #include <algorithm>
    using namespace std;
    struct people {
        string id;
        int fr, ln, lr, score;
    };
    vector<vector<people>> v;
    vector<people> res;
    bool cmp(people& p1, people& p2){
        return p1.score == p2.score ? p1.id < p2.id: p1.score > p2.score;
    }
    int main(){
        int N, M;
        cin >> N;
        v.resize(N);
        people tmp;
        for(int i = 0; i < N; i++){
            cin >> M;
            tmp.ln = i + 1;
            while(M--) {
                cin >> tmp.id >> tmp.score;
                v[i].push_back(tmp);
            }
            sort(v[i].begin(), v[i].end(), cmp);
            if(v[i].size() != 0){
                v[i][0].lr = 1;
                for(int j = 2; j <= v[i].size(); j++)
                    if(v[i][j-1].score != v[i][j-2].score) v[i][j-1].lr = j;
                    else v[i][j-1].lr = v[i][j-2].lr;
            }
        }
        for(int i = 0;i < v.size(); i++)
            for(int j = 0;j < v[i].size(); j++)
                res.push_back(v[i][j]);
        sort(res.begin(), res.end(), cmp);
        res[0].fr = 1;
        for(int i = 2;i <= res.size(); i++)
            if(res[i-1].score != res[i-2].score) res[i-1].fr = i;
            else res[i-1].fr = res[i-2].fr;
        cout << res.size() << endl;
        for(int i = 0; i < res.size(); i++)
            cout << res[i].id << " " << res[i].fr << " "
                << res[i].ln << " " << res[i].lr << endl;return 0;
    }
  • 相关阅读:
    IE浏览器Ajax缓存问题小结
    2015第50周二
    2015第50周一了解微服务架构
    2015第49周日
    2015第49周六
    2015第49周五
    2015第49周四
    2015第49周三
    0当执行游戏xc000007b错误的解决方法
    微软的最高市值是多少?
  • 原文地址:https://www.cnblogs.com/littlepage/p/12236015.html
Copyright © 2011-2022 走看看