zoukankan      html  css  js  c++  java
  • PAT Advanced 1003 Emergency (25分)

    As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

    Input Specification:

    Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤) - the number of cities (and the cities are numbered from 0 to N1), M - the number of roads, C1​​ and C2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1​​, c2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1​​ to C2​​.

    Output Specification:

    For each test case, print in one line two numbers: the number of different shortest paths between C1​​ and C2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

    Sample Input:

    5 6 0 2
    1 2 1 5 3
    0 1 1
    0 2 2
    0 3 1
    1 2 1
    2 4 1
    3 4 1
    
     

    Sample Output:

    2 4

    这道题看了柳婼解法,实际是求最短路径。

    告诉了边,存储在edge二维数组,告诉了权值,存储在weight

    告诉了距离,存储在dis,

    num存储路径条数,w存储权值和(求援人数之和)

    如果最短路径,先赋值,如果和之前路径相等,要同时更新几个值

    #include <iostream>
    #include <algorithm>
    using namespace std;
    int n, m, c1, c2;
    int edge[510][510], weight[510], dis[510], num[510], w[510];
    bool vis[510];
    const int inf = 99999999;
    int main() {
        scanf("%d%d%d%d", &n, &m, &c1, &c2);
        for(int i = 0; i < n; i++)
            scanf("%d", &weight[i]);
        fill(edge[0], edge[0] + 510 * 510, inf);
        fill(dis, dis + 510, inf);
        int a, b, c;
        for(int i = 0; i < m; i++){
            scanf("%d%d%d", &a, &b, &c);
            edge[a][b] = edge[b][a] = c;
        }
        dis[c1] = 0;
        w[c1] = weight[c1];
        num[c1] = 1;
        for(int i = 0;i < n; i++) {
            int u = -1, minn = inf;
            for(int j = 0; j < n; j++){
                if(vis[j] == false && dis[j] < minn) {
                    u = j;
                    minn = dis[j];
                }
            }
            if(u == -1) break;
            vis[u] = true;
            for(int  v = 0; v < n; v++) {
                if(vis[v] == false && edge[u][v] != inf) {
                    if(dis[u] + edge[u][v] < dis[v]) {
                        dis[v] = dis[u] + edge[u][v];
                        num[v] = num[u];
                        w[v] = w[u] + weight[v];
                    }else if(dis[u] + edge[u][v] == dis[v]) {
                        num[v] = num[v] + num[u];
                        if(w[u] + weight[v] > w[v])
                            w[v] = w[u] + weight[v];
                    }
                }
            }
        }
        printf("%d %d", num[c2], w[c2]);
        return 0;
    }
  • 相关阅读:
    蓝桥杯——一步之遥,扩展gcd的应用
    质数唯一分解定理应用——多个数的最小公约数和最大公倍数
    蓝桥杯训练 ——天平称重
    蓝桥杯 奇怪的捐赠——进制的运用
    Kubernetes-基本概念
    Docker-基本概念
    虚拟化向容器化发展
    Kubernetes-服务连接和暴露(endpoints资源)
    Kubernetes-NodePort
    Kubernetes-Load Balancer
  • 原文地址:https://www.cnblogs.com/littlepage/p/12244940.html
Copyright © 2011-2022 走看看