zoukankan      html  css  js  c++  java
  • PAT Advanced 1078 Hashing (25分)

    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be ( where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤) and N (≤) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

    Sample Input:

    4 4
    10 6 4 15
    
     

    Sample Output:

    0 1 4 -

    这道题目是一个哈希问题,哈希表长度为比大于等于size的最小素数。

    解决哈希冲突的办法是平方探测法,从1到size-1去解决冲突,(num + i * i) % size

    如果还是不行,则输出-

    #include <iostream>
    #include <map>
    using namespace std;
    bool isPrime(int N) {
        if(N <= 1) return false;
        for(int i = 2; i * i <= N; i++)
            if(N % i == 0) return false;
        return true;
    }
    int main() {
        int M, N, tmp;
        map<int, bool> m;
        scanf("%d%d", &M, &N);
        while(!isPrime(M)) M++;
        while(N--) {
            scanf("%d", &tmp);
            bool out = false;
            for(int i = 0; i < M; i++) {
                if(m[(i * i + tmp) % M] == false) {
                    m[(i * i + tmp) % M] = true;
                    printf("%d", (i * i + tmp) % M);
                    out = true;
                    break;
                }
            }
            if(!out) printf("-");
            if(N != 0) printf(" ");
        }
        system("pause");
        return 0;
    }
  • 相关阅读:
    Thinking in Java Reading Note(9.接口)
    Thinking in java Reading Note(8.多态)
    Thinking in Java Reading Note(7.复用类)
    SQL必知必会
    Thinking in Java Reading Note(5.初始化与清理)
    Thinking in Java Reading Note(2.一切都是对象)
    鸟哥的Linux私房菜笔记(1.基础)
    Thinking in Java Reading Note(1.对象导论)
    CoreJava2 Reading Note(2:I/O)
    CoreJava2 Reading Note(1:Stream)
  • 原文地址:https://www.cnblogs.com/littlepage/p/12268691.html
Copyright © 2011-2022 走看看