zoukankan      html  css  js  c++  java
  • 1119 Pre- and Post-order Traversals (30分)

    Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

    Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input 1:

    7
    1 2 3 4 6 7 5
    2 6 7 4 5 3 1
    
     

    Sample Output 1:

    Yes
    2 1 6 4 7 3 5
    
     

    Sample Input 2:

    4
    1 2 3 4
    2 4 3 1
    
     

    Sample Output 2:

    No
    2 1 3 4
    
     
    #include <iostream>
    using namespace std;
    int N, index_in = 0, uniq = true;
    int pre[99999], post[99999], in[99999];
    struct node {
        int val;
        node *left, *right;
        node(int v): val(v), left(NULL), right(NULL){}
    }*root;
    node *build(int pre_l, int pre_r, int post_l, int post_r) {
        if(pre_l > pre_r) return NULL;
        if(pre_l == pre_r) return new node(pre[pre_l]);
        node *n = new node(pre[pre_l]);
        int k = post_l;
        while(k < post_r && post[k] != pre[pre_l + 1]) k++;
        n->left = build(pre_l + 1, pre_l + 1 + k - post_l, post_l , k);
        n->right = build(pre_l + 1 + k - post_l + 1, pre_r, k + 1, post_r - 1);
        return n;
    }
    void inorder(node *n) {
        if(!n) return;
        if((n->left && !n->right) || (n->right && !n->left)) uniq = false;
        inorder(n->left);
        in[index_in++] = n->val;
        inorder(n->right);
    }
    int main() {
        scanf("%d", &N);
        for(int i = 0; i < N; i++)
            scanf("%d", pre + i);
        for(int i = 0; i < N; i++)
            scanf("%d", post + i);
        root = build(0, N-1, 0, N-1);
        inorder(root);
        printf("%s
    %d", uniq ? "Yes":"No", in[0]);
        for(int i = 1; i < N; i++)
            printf(" %d", in[i]);
        putchar('
    ');
        return 0;
    }
     
  • 相关阅读:
    16. Vue 登录存储
    JS 10位、13位时间戳转日期
    14.Vue 定义全局函数
    13.Vue+Element UI实现复制内容
    12.Vue+Element UI 获取input的值
    11.Vue安装Axios及使用
    Layui入手
    MongoDB自启动设置
    sql数据统计
    sql查询总结
  • 原文地址:https://www.cnblogs.com/littlepage/p/12664194.html
Copyright © 2011-2022 走看看