zoukankan      html  css  js  c++  java
  • 1152 Google Recruitment (20分)

    In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

    prime.jpg

    The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

    Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

    Input Specification:

    Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

    Output Specification:

    For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

    Sample Input 1:

    20 5
    23654987725541023819
    
     

    Sample Output 1:

    49877
    
     

    Sample Input 2:

    10 3
    2468024680
    
     

    Sample Output 2:

    404

    谷歌的招聘,给定一串数字,打印中间N位数字的素数

    #include <iostream>
    using namespace std;
    bool isPrime(int N) {
        if(N == 2 || N == 3) return true;
        for(int i = 2; i * i <= N; i++) 
            if(N % i == 0) return  false;
        return true;
    }
    int main() {
        int L, K;
        string data;
        cin >> L >> K >> data;
        for(int i = 0; i < data.length() - K + 1; i++) {
            string tmp_str = data.substr(i, K);
            int tmp = stoi(tmp_str);
            bool right = isPrime(tmp);
            if(right) {
                printf("%s", tmp_str.c_str());
                exit(0);
            } 
        }
        printf("404");
        return 0;
    }
  • 相关阅读:
    致 CODING 用户的元宵问候
    持续集成之理论篇
    基于 CODING 的 Spring Boot 持续集成项目
    使用 CODING 进行 Hexo 项目的持续集成
    使用 CODING 进行 Spring Boot 项目的集成
    三种前端模块化规范
    XSS和CSRF
    小问题填坑,关于obj.x和obj["x"]
    说一个闭包在实际开发中的应用
    关于return的分号自动插入问题
  • 原文地址:https://www.cnblogs.com/littlepage/p/12817932.html
Copyright © 2011-2022 走看看