zoukankan      html  css  js  c++  java
  • 1119 Pre- and Post-order Traversals (30分)

    Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

    Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input 1:

    7
    1 2 3 4 6 7 5
    2 6 7 4 5 3 1
    
     

    Sample Output 1:

    Yes
    2 1 6 4 7 3 5
    
     

    Sample Input 2:

    4
    1 2 3 4
    2 4 3 1
    
     

    Sample Output 2:

    No
    2 1 3 4

    给定一个先序序列和后序序列,求是否构成唯一的一个树,如果是打印Yes,不是打印No,并且打印其中一个树。

    前后建树操作:使用一个指针指向pre_l的后一个,在后序中进行划分。

    如果一个树只有右子树没有左子树(或者只有左子树,没有右子树),那么左右子树等价,则树不唯一。

    #include <iostream>
    using namespace std;
    int N, index_in = 0, uniq = true;
    int pre[99999], post[99999], in[99999];
    struct node {
        int val;
        node *left, *right;
        node(int v): val(v), left(NULL), right(NULL){}
    }*root;
    node *build(int pre_l, int pre_r, int post_l, int post_r) {
        if(pre_l > pre_r) return NULL;
        if(pre_l == pre_r) return new node(pre[pre_l]);
        node *n = new node(pre[pre_l]);
        int k = post_l;
        while(k < post_r && post[k] != pre[pre_l + 1]) k++;
        n->left = build(pre_l + 1, pre_l + 1 + k - post_l, post_l , k);
        n->right = build(pre_l + 1 + k - post_l + 1, pre_r, k + 1, post_r - 1);
        return n;
    }
    void inorder(node *n) {
        if(!n) return;
        if((n->left && !n->right) || (n->right && !n->left)) uniq = false;
        inorder(n->left);
        in[index_in++] = n->val;
        inorder(n->right);
    }
    int main() {
        scanf("%d", &N);
        for(int i = 0; i < N; i++)
            scanf("%d", pre + i);
        for(int i = 0; i < N; i++)
            scanf("%d", post + i);
        root = build(0, N-1, 0, N-1);
        inorder(root);
        printf("%s
    %d", uniq ? "Yes":"No", in[0]);
        for(int i = 1; i < N; i++)
            printf(" %d", in[i]);
        putchar('
    ');
        return 0;
    }
  • 相关阅读:
    ORACLE 使用笔记
    Python资源大全,让你相见恨晚的Python库
    基于python的k-s值计算
    sklearn聚类模型:基于密度的DBSCAN;基于混合高斯模型的GMM
    skearn学习路径
    透彻形象理解核函数
    LDA降维与PCA降维对比
    sklearn 岭回归
    GBDT、XGBOOST、LightGBM对比学习及调参
    sklearn,交叉验证中的分层抽样
  • 原文地址:https://www.cnblogs.com/littlepage/p/12847036.html
Copyright © 2011-2022 走看看