zoukankan      html  css  js  c++  java
  • 1106 Lowest Price in Supply Chain (25分)

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

    Input Specification:

    Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N1, and the root supplier's ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    Ki​​ ID[1] ID[2] ... ID[Ki​​]

    where in the i-th line, Ki​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj​​ being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1.

    Sample Input:

    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0
    2 6 1
    1 8
    0
    0
    0
    
     

    Sample Output:

    1.8362 2

    供应链问题:已知root节点的价格,求零售商最便宜的价格和数量。

    我们仅需要在递归的时候层层传递即可。

    #include <iostream>
    #include <vector>
    using namespace std;
    struct node {
        vector<int> child;
    };
    int N, tmp, K; double P, r;
    int minnLevel = 99999999, cnt = 0; double price;
    vector<node> v;
    void dfs(int root, int level, double tmpPrice) {
        if(v[root].child.size() == 0) {
            if(level < minnLevel) {
                minnLevel = level;
                cnt = 1;
                price = tmpPrice;
            } else if(level == minnLevel) cnt++;
            return;
        }
        for(int i = 0; i < v[root].child.size(); i++) 
            dfs(v[root].child[i], level + 1, tmpPrice * (1.0 + r/100.0));
    }
    int main() {
        scanf("%d%lf%lf", &N, &P, &r);
        v.resize(N);
        for(int i = 0; i < N; i++) {
            scanf("%d", &K);
            while(K--) {
                scanf("%d", &tmp);
                v[i].child.push_back(tmp);
            }
        }
        dfs(0, 0, P);
        printf("%.4f %d", price, cnt);
        return 0;
    }
  • 相关阅读:
    java反序列化盲打与手工测试
    centos7下面利用服务启动empire后门的方法
    部分APP无法代理抓包的原因及解决方法(flutter 应用抓包)
    代码审计入门之Jeeplus代码审计
    代码审计新手入门-xdcms_v1.0
    Web应用安全模糊测试之路
    java代码审计文章集合
    Java框架级SSM代码审计思路
    [翻译] 使用Frida来hack安卓APP(一)
    基于Websocket接口的SQL注入利用
  • 原文地址:https://www.cnblogs.com/littlepage/p/12875704.html
Copyright © 2011-2022 走看看