zoukankan      html  css  js  c++  java
  • 1092 To Buy or Not to Buy (20分)

    Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

    For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

    figbuy.jpg

    Figure 1

    Input Specification:

    Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

    Output Specification:

    For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

    Sample Input 1:

    ppRYYGrrYBR2258
    YrR8RrY
    
     

    Sample Output 1:

    Yes 8
    
     

    Sample Input 2:

    ppRYYGrrYB225
    YrR8RrY
    
     

    Sample Output 2:

    No 2

    数一数串中的字母

    #include <iostream>
    #include <unordered_map>
    using namespace std;
    int main(){
        string A, B;
        unordered_map<char, int> m;
        int lost = 0;
        getline(cin, A);
        getline(cin, B);
        for(int i = 0; i < A.length(); i++)
            m[A[i]]++;
        for(int i = 0; i < B.length(); i++)
            if(m[B[i]] > 0) m[B[i]]--;
            else lost++;
        if(lost != 0) cout << "No " << lost;
        else cout << "Yes " << A.length() - B.length();
        return 0;
    }
  • 相关阅读:
    SqlBulkCopy 的2篇不错的文章
    xml、json反序列化得到相应的类
    DataTable的使用操作持续更新
    asp.net mvc 添加下拉列表
    asp.net mvc 简单实现权限控制
    ASP.NET 实现上传EXCEL,利用NOPI操作,转换得到DataTable
    asp.net mvc code first 在本地数据库中生成数据库
    第一个随笔
    vb中字母排列组合输出函数
    使用SQL语句查询某表中所有的主键、唯一索引以及这些主键、索引所包含的字段
  • 原文地址:https://www.cnblogs.com/littlepage/p/12910263.html
Copyright © 2011-2022 走看看