zoukankan      html  css  js  c++  java
  • 【poj2367】Genealogical tree

    Description

    The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
    And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
    Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

    Input

    The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

    Output

    The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

    Sample Input

    5
    0
    4 5 1 0
    1 0
    5 3 0
    3 0
    

    Sample Output

    2 4 5 3 1

    Source

    题解

    求拓扑序列,拓扑排序

    #include<iostream>
    #include<cstdio>
    #define N 110
    using namespace std;
    struct edge_node
    {
        int to,next;
    }e[N*N];
    int head[N];
    int rudu[N];
    int q[N];
    int n,cnt,h,t;
    int main()
    {
        scanf("%d",&n);
        for (int u=1;u<=n;u++)
        {
            int v;
            for (;scanf("%d",&v) && v;)
            {
                e[++cnt].to = v;
                e[cnt].next = head[u];
                head[u] = cnt;
                rudu[v] ++;
            }
        }
        for (int i=1;i<=n;i++)
            if (rudu[i] == 0)
                q[++t] = i;
        for (;h<t;)
        {
            int u = q[++h];
            for (int i = head[u];i;i = e[i].next)
            {
                int v = e[i].to;
                rudu[v] -- ;
                if (!rudu[v])
                    q[++t] = v;
            }
            printf("%d ",u);
        }
    }
  • 相关阅读:
    LAMP----linux+apache+mysql+php详细安装步骤之一APACHE篇(openldap等)
    Apache2 httpd.conf 配置详解
    Apache+php+mysql的安装与配置
    linux PHP 安装及 GD库安装
    Linux下安装PHP的GD支持库
    linux下tar.gz、tar、bz2、zip等解压缩、压缩命令
    Android中Context详解 ---- 你所不知道的Context(转)
    Android简单文件浏览器源代码 (转)
    Android入门之文件系统操作(一)简单的文件浏览器 (转)
    Android入门之文件系统操作
  • 原文地址:https://www.cnblogs.com/liumengyue/p/5495523.html
Copyright © 2011-2022 走看看