zoukankan      html  css  js  c++  java
  • N

    Description

    相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
     

    Input

    输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。 
    每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。 
     

    Output

    每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
     

    Sample Input

    2 2 10 10 20 20 3 1 1 2 2 1000 1000
     

    Sample Output

    1414.2 oh!
    分析:看题意可以明白只要在任意个合法的桥之间加上边,进行最小生成树求解即可,注意要判断无法构成生成树的情况。
    ************************************
    注意:不能用int提高精度判定,只能使用double..要不就会WA
    #include<algorithm>
    #include<stdio.h>
    #include<string.h>
    #include<queue>
    #include<math.h>
    using namespace std;

    const int maxn = 105;
    const double oo = 0x7fffffff;

    double G[maxn][maxn];
    struct point{int x, y;}p[maxn];

    double Len(point a, point b)//求两个小岛的距离,不合法返回oo
    {
        int x = a.x-b.x;
        int y = a.y-b.y;
        double l = sqrt(x*x + y*y);

        if(l>=10.0 && l<=1000.0)
            return l;//合法范围
        return oo;
    }
    double Prim(int N)
    {
        int vis[maxn]={01};
        int i, T = N-1;
        double dist[maxn], ans = 0;

        for(i=1; i<=N; i++)
            dist[i] = G[1][i];
        while(T--)
        {
            int k = -1;
            double mini = oo;

            for(i=1; i<=N; i++)
            {
                if(!vis[i] && mini > dist[i])
                    mini = dist[i], k=i;
            }

            if(k == -1)return -1;
            vis[k] = true, ans += mini;

            for(i=1; i<=N; i++)if(!vis[i])
                dist[i] = min(dist[i], G[k][i]);
        }

        return ans;
    }

    int main()
    {
        int T;

        scanf("%d", &T);

        while(T--)
        {
            int i, j, N;

            scanf("%d", &N);

            for(i=1; i<=N; i++)
                scanf("%d%d", &p[i].x, &p[i].y);

            for(i=1; i<=N; i++)
            for(j=i; j<=N; j++)
            {
                if(j == i)G[i][j] = 0.0;
                else G[i][j] = G[j][i] = Len(p[i], p[j]);
            }

            double ans = Prim(N);

            if(ans < 0)
                printf("oh! ");
            else
                printf("%.1f ", ans*100 );
        }

        return 0; 

    }

  • 相关阅读:
    eclipse报错 : One or more constraints have not been satisfied.
    关于一个计算机同时装两个jdk对应两个eclipse
    开发测试类2
    工作中测试类1
    Spring 读取classpath下的文件存到map里面
    CentOS6下安装JDK并且部署tomcat容器
    ConOS安装mysql5.7 及简单配置
    用sqlyog迁移mysql数据库
    FindBugs缺陷库
    使用NumberPicker定制自己喜欢的Date&TimePicker
  • 原文地址:https://www.cnblogs.com/liuxin13/p/4676170.html
Copyright © 2011-2022 走看看