zoukankan      html  css  js  c++  java
  • POJ 1564 Sum It Up

    题目链接:http://poj.org/problem?id=1564

    Description

    Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

    Input

    The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

    Output

    For each test case, first output a line containing `Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.

    Sample Input

    4 6 4 3 2 2 1 1
    5 3 2 1 1
    400 12 50 50 50 50 50 50 25 25 25 25 25 25
    0 0

    Sample Output

    Sums of 4:
    4
    3+1
    2+2
    2+1+1
    Sums of 5:
    NONE
    Sums of 400:
    50+50+50+50+50+50+25+25+25+25
    50+50+50+50+50+25+25+25+25+25+25
    
    想了半个多小时,打了一个很挫的代码,还不对。甚是无语!%>_<%
    后来看了一下别人的代码,发现判重判的很犀利,短短的代码涵盖了所有要求,牛啊!
    最主要的代码:(即判重)
    for(int i=index;i<=n;++i)
        {
            if((i==index || num[i]!=num[i-1])&&(num[i]<=left))
               {
                   step[cnt]=num[i];
                   dfs(i+1,cnt+1,left-num[i]);
               }
        }

     我在看了别人的代码以后自己编了一个,又加了一些优化:

    1.输入的数比t大的时候可以去掉

    2.要用的数比剩下的数还大时可以跳过

    成功优化到0ms

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    
    int step[15];
    int num[15];
    int t,n;
    bool No_Found=1;  //NOT  FOUND ANS
    void dfs(int index,int cnt,int left)
    {
        if(left==0)
        {
            No_Found=0;
            for(int i=1;i<cnt;++i)
            {
                if(i==1)
                {
                    printf("%d",step[i]);
                }
                else
                {
                    printf("+%d",step[i]);
                }
            }
            printf("\n");
            return ;
        }
        for(int i=index;i<=n;++i)
        {
            if((i==index || num[i]!=num[i-1])&&(num[i]<=left))
               {
                   step[cnt]=num[i];
                   dfs(i+1,cnt+1,left-num[i]);
               }
        }
        return;
    }
    int main()
    {
        int tmp;
        while(scanf("%d%d",&t,&n)&&n)
        {
            for(int i=1;i<=n;++i)
            {
                scanf("%d",&tmp);
                if(tmp>t)
                {
                    n--;
                    i--;
                }
                else
                {
                    num[i]=tmp;
                }
            }
            printf("Sums of %d:\n",t);
            No_Found=1;
            dfs(1,1,t);
            if(No_Found)
            {
                printf("NONE\n");
            }
        }
    }

    网上说这是一道水题,是吗?希望有一天我也这么说吧!

    但我想这道题没想出来。

  • 相关阅读:
    spring项目(springmvc)(多模块/单模块)maven打包引入第三方jar方式,使用scope:system配置systemPath编译,不用添加到本地仓库!
    Mysql 执行效率 性能综合贴
    前端Js框架 UI框架汇总 特性 适用范围 选择
    通用 正则表达式 C# (.NET)Regex 总结
    VSCode Node cannot launch program setting the 'outFiles' attribute might help
    CSS常见问题,定位技巧总结
    java 欢迎页 主页 设置为servlet的方法
    MSSQL Server 及 MSSQL Express版本 自动备份
    SQL Server 2008 R2 安装 下载
    mysql 日期计算集合
  • 原文地址:https://www.cnblogs.com/liuyalunuli/p/2703780.html
Copyright © 2011-2022 走看看