zoukankan      html  css  js  c++  java
  • HDU 1150--Machine Schedule

    Problem Description
    As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

    There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

    For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

    Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.
     
     
    Input
    The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

    The input will be terminated by a line containing a single zero.
     

    Output
    The output should be one integer per line, which means the minimal times of restarting machine.
     

    Sample Input
    5 5 10
    0 1 1
    1 1 2
    2 1 3
    3 1 4
    4 2 1
    5 2 2
    6 2 3
    7 2 4
    8 3 3
    9 4 3
    0
     

    Sample Output
    3

    这道题目用到了一个定理:

    二分图的最小覆盖=二分图的最大匹配

    代码:

    #include<iostream>
    #include<string.h>
    #include<cstdio>
    using namespace std;
    #define MAXN 220
    int n,m,k;
    int vis[MAXN];
    int liner[MAXN];
    int G[MAXN][MAXN];
    int dfs(int x)
    {
        for(int i=0;i<m;i++){
            if(G[x][i]&&!vis[i]){
                vis[i]=1;
                if(liner[i]==-1||dfs(liner[i])){
                    liner[i]=x;
                    return 1;
                }
            }
        }
        return 0;
    }
    int zuida()
    {
        int res=0;
        memset(liner,-1,sizeof(liner));
        for(int i=0;i<n;i++){
            memset(vis,0,sizeof(vis));
            if(dfs(i)) res++;
        }
        return res;
    }
    int main()
    {
        freopen("data.in","r",stdin);
        int p,x,y;
        while(cin>>n){
            if(n==0) break;
            cin>>m>>k;
            memset(G,0,sizeof(G));
            for(int i=0;i<k;i++){
                cin>>p>>x>>y;
                if(x!=0&&y!=0)
                G[x][y]=1;
            }
            cout<<zuida()<<endl;
        }
    }
  • 相关阅读:
    [Oracle]如何为数据库设置Event(eg: ORA-00235)
    [Oracle]如何为数据库设置Event(eg: ORA-00235)
    C++常用字符串分割方法实例汇总
    C++常用字符串分割方法实例汇总
    C#学习笔记——常量、字段以及事件
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    混淆电路Garbled Circuit介绍
    安全计算实现方法概览
  • 原文地址:https://www.cnblogs.com/liuzhanshan/p/6204447.html
Copyright © 2011-2022 走看看