zoukankan      html  css  js  c++  java
  • 1045 Favorite Color Stripe 最长不减序列 dp

     
     

    Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

    It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

    Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

    Output Specification:

    For each test case, simply print in a line the maximum length of Eva's favorite stripe.

    Sample Input:

    6
    5 2 3 1 5 6
    12 2 2 4 1 5 5 6 3 1 1 5 6
    

    Sample Output:

    7
    dp[i]是以a[i]结尾的最长不减序列数
    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstring>
    #define ll long long
    #define inf 10005
    using namespace std;
    int main()
    {
        int n,m,l,book[inf],a[inf],temp,num=0,dp[inf],maxn=0;
        cin>>m;
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            cin>>temp;
            book[temp]=i;
        }
        cin>>l;
        for(int i=0;i<l;i++)
        {
            cin>>temp;
            if(book[temp]>=1)
            {
                a[num++]=book[temp];
            }
        }
        for(int i=0;i<num;i++)
        {
            dp[i]=1;
            for(int j=0;j<i;j++)
            {
                if(a[i]>=a[j])
                dp[i]=max(dp[i],dp[j]+1);
            }
            maxn=max(maxn,dp[i]);
        }
        cout<<maxn<<endl;
        return 0;
    }
     
    如果你够坚强够勇敢,你就能驾驭他们
  • 相关阅读:
    java第一次作业
    第十一次作业
    第十次作业
    第九次作业
    第八次作业
    第七次作业
    第六次作业
    第五次作业
    实验四,实验五
    Java_实验二
  • 原文地址:https://www.cnblogs.com/liuzhaojun/p/11164075.html
Copyright © 2011-2022 走看看