zoukankan      html  css  js  c++  java
  • 乙级 1095 解码PAT准考证

    PAT 准考证号由 4 部分组成:

    • 第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
    • 第 2~4 位是考场编号,范围从 101 到 999;
    • 第 5~10 位是考试日期,格式为年、月、日顺次各占 2 位;
    • 最后 11~13 位是考生编号,范围从 000 到 999。

    现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。

    输入格式:

    输入首先在一行中给出两个正整数 N(≤)和 M(≤),分别为考生人数和统计要求的个数。

    接下来 N 行,每行给出一个考生的准考证号和其分数(在区间 [ 内的整数),其间以空格分隔。

    考生信息之后,再给出 M 行,每行给出一个统计要求,格式为:类型 指令,其中

    • 类型 为 1 表示要求按分数非升序输出某个指定级别的考生的成绩,对应的 指令 则给出代表指定级别的字母;
    • 类型 为 2 表示要求将某指定考场的考生人数和总分统计输出,对应的 指令 则给出指定考场的编号;
    • 类型 为 3 表示要求将某指定日期的考生人数分考场统计输出,对应的 指令 则给出指定日期,格式与准考证上日期相同。

    输出格式:

    对每项统计要求,首先在一行中输出 Case #: 要求,其中 # 是该项要求的编号,从 1 开始;要求 即复制输入给出的要求。随后输出相应的统计结果:

    • 类型 为 1 的指令,输出格式与输入的考生信息格式相同,即 准考证号 成绩。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);
    • 类型 为 2 的指令,按 人数 总分 的格式输出;
    • 类型 为 3 的指令,输出按人数非递增顺序,格式为 考场编号 总人数。若人数并列则按考场编号递增顺序输出。

    如果查询结果为空,则输出 NA

    输入样例:

    8 4
    B123180908127 99
    B102180908003 86
    A112180318002 98
    T107150310127 62
    A107180908108 100
    T123180908010 78
    B112160918035 88
    A107180908021 98
    1 A
    2 107
    3 180908
    2 999
    

    输出样例:

    Case 1: 1 A
    A107180908108 100
    A107180908021 98
    A112180318002 98
    Case 2: 2 107
    3 260
    Case 3: 3 180908
    107 2
    123 2
    102 1
    Case 4: 2 999
    NA
    不明白为什么,这题挺考基本功的
    求大佬解答

    
    
    #include<iostream>
    #include<cstring>
    #include<algorithm> 
    using namespace std;
    const int inf=10010;
    struct node{
        string sno;
        int score; 
    };
    struct node1{
        int s;
        int count; 
    };
    bool cmp1(node1 a,node1 b)
    {
        if(a.count==b.count)
        return a.s<b.s;
        return a.count>b.count ;
    }
    bool cmp(node a,node b)
    {
        if(a.score==b.score)
        return a.sno<b.sno;
        return a.score >b.score ;
    }
    int main()
    {
        node1 c[inf];
        bool flag=false;
        node a[inf];
        int n,m,type,b[inf],y;
        string ins;
        cin>>n>>m;
        for(int i=0;i<n;i++)
        {
            cin>>a[i].sno>>a[i].score;
        }
        for(int j=1;j<=m;j++)
        {
            flag=false;
            cin>>type>>ins;
            cout<<"Case "<<j<<": ";
            cout<<type<<" "<<ins<<endl;
            if(type==1)
            {
                sort(a,a+n,cmp);
                for(int i=0;i<n;i++)
                {
                    if(a[i].sno[0]==ins[0])
                    {
                        flag=true;
                        cout<<a[i].sno<<" "<<a[i].score<<endl;
                    }
                }
            }
            if(type==2)
            {
                int cnt=0,sum=0;
                for(int i=0;i<n;i++)
                {
                    if(a[i].sno[1]==ins[0]&&a[i].sno[2]==ins[1]&&a[i].sno[3]==ins[2])
                    {
                        flag=true;
                        sum=sum+a[i].score ;
                        cnt++;
                    }
                }
                if(flag==true)
                cout<<cnt<<" "<<sum<<endl;
            }
            if(type==3)
            {
                for(int i=0;i<n;i++)
                {
                    if(a[i].sno[4]==ins[0]&&a[i].sno[5]==ins[1]&&a[i].sno[6]==ins[2]&&a[i].sno[7]==ins[3]&&a[i].sno[8]==ins[4]&&a[i].sno[9]==ins[5])
                    {
                        flag=true;
                        int temp=0,k=1;
                        while(k<4)
                        {
                            temp=temp*10+(a[i].sno[k]-'0');
                            k++;
                        }
                        //cout<<temp<<endl;
                        b[temp]++;
                    }
                }
                int j=0;
                for(int i=100;i<1000;i++)
                {
                    if(b[i]!=0)
                    {
                        c[j].s=i;
                        c[j].count=b[i];
                        j++;
                        y=j;
                    }
                }
                sort(c,c+y,cmp1);
                for(int i=0;i<y;i++)
                if(flag==true)
                cout<<c[i].s<<" "<<c[i].count<<endl;
            }
            if(flag==false)
            cout<<"NA"<<endl;
        }
        return 0;
     } 
    如果你够坚强够勇敢,你就能驾驭他们
  • 相关阅读:
    MTK相关汇总
    Android TV 学习笔记
    进程限制_limit
    Linux TV 学习笔记
    Linux firmware子系统的实现机制学习笔记
    C++ STL deque
    C++ STL Vector
    C++ STL几种数据结构对比
    vector系列--creating vector of local structure、vector of structs initialization
    vector系列--vector<unique_ptr<>>赋值给vector<unique_ptr<>>
  • 原文地址:https://www.cnblogs.com/liuzhaojun/p/11193994.html
Copyright © 2011-2022 走看看