zoukankan      html  css  js  c++  java
  • 1032 Sharing

    To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

    fig.jpg

    Figure 1

    You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −.

    Then N lines follow, each describes a node in the format:

    Address Data Next
    

    whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

    Output Specification:

    For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

    Sample Input 1:

    11111 22222 9
    67890 i 00002
    00010 a 12345
    00003 g -1
    12345 D 67890
    00002 n 00003
    22222 B 23456
    11111 L 00001
    23456 e 67890
    00001 o 00010
    

    Sample Output 1:

    67890
    

    Sample Input 2:

    00001 00002 4
    00001 a 10001
    10001 s -1
    00002 a 10002
    10002 t -1
    

    Sample Output 2:

    -1
    我的
    #include<iostream>
    #include<cstring>
    #include<algorithm>
    #include<cstdio>
    using namespace std;
    struct node{
        char c;
        string pos;
        string next;
    };
    const int inf=100005;
    node a[inf];
    string p1,p2;
    int n,p11,p22,p222;
    int findindex(int k)
    {
        for(int i=0;i<n;i++)
        {
            if(a[i].pos==a[k].next)
            {
                 return i;
            }
        }
        return -1;
    }
    int main()
    {
        cin>>p1>>p2>>n;
        for(int i=0;i<n;i++)
        {
            cin>>a[i].pos>>a[i].c>>a[i].next ;
            if(a[i].pos==p1)
            p11=i;
            if(a[i].pos==p2)
            p22=i;
        }
        p222=p22;
        /*if(a[p11].pos==a[p22].pos)
        {
            cout<<a[p11].pos<<endl;
                return 0;
        }*/
        while(a[p11].next!="-1"&&p11!=-1)
        {
        while(a[p22].next!="-1"&&p22!=-1)
        {
            //p22=findindex(p22);
            if(a[p11].pos==a[p22].pos)
            {
                cout<<a[p11].pos<<endl;
                return 0;
            }
            p22=findindex(p22);
        }
        p22=p222;
        p11=findindex(p11);
        }
        cout<<"-1"<<endl;
        return 0;
    }

    柳神

    我的时间复杂度为n^2;

    柳神 n

    数据结构和算法不同,导致时间复杂度不同

    关键我的没拿到满分  /(ㄒoㄒ)/~~

    如果你够坚强够勇敢,你就能驾驭他们
  • 相关阅读:
    四则运算
    读书计划
    典型用户和场景分析
    课堂练习--电梯调度
    重力解锁--用户需求调研
    书籍促销活动优惠问题
    小组开发项目--NABC分析
    梦断代码读后感之终结篇
    结对开发-求环状二维数组最大子数组
    结对开发之大数溢出
  • 原文地址:https://www.cnblogs.com/liuzhaojun/p/11213886.html
Copyright © 2011-2022 走看看