zoukankan      html  css  js  c++  java
  • 1053 Path of Equal Weight

    Given a non-empty tree with root R, and with weight Wi​​ assigned to each tree node Ti​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

    Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 0, the number of nodes in a tree, M (<), the number of non-leaf nodes, and 0, the given weight number. The next line contains N positive numbers where Wi​​ (<) corresponds to the tree node Ti​​. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]
    

    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

    Output Specification:

    For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

    Note: sequence { is said to be greater than sequence { if there exists 1 such that Ai​​=Bi​​ for ,, and Ak+1​​>Bk+1​​.

    Sample Input:

    20 9 24
    10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
    00 4 01 02 03 04
    02 1 05
    04 2 06 07
    03 3 11 12 13
    06 1 09
    07 2 08 10
    16 1 15
    13 3 14 16 17
    17 2 18 19
    

    Sample Output:

    10 5 2 7
    10 4 10
    10 3 3 6 2
    10 3 3 6 2

    #include<iostream>
    #include<string>
    #include<algorithm>
    using namespace std;
    const int maxn=100;
    struct node{
        int id;
        int value;
        int num1=0;
        int sub[maxn];
    };
    node str[maxn];
    int a[maxn];
    int n,m,w,flag=0;
    string s[maxn];
    int cmp(string s1,string s2)
    {
        return s1>s2;
    }
    void dfs(int id1,int w1,int cnt)
    {
        if(w1<0)
        return ;
        if(w1==0&&str[id1].num1==0)
        {
            s[flag]="";
        for(int i=0;i<cnt;i++)
        {
            s[flag]=s[flag]+char(a[i]+'0');
        }
        //cout<<flag<<endl;
        //cout<<s[flag]<<endl;
        flag++;
       }
        for(int i=0;i<str[id1].num1;i++)
        {
            a[cnt]=str[str[id1].sub[i]].value;
            dfs(str[id1].sub[i],w1-str[str[id1].sub[i]].value,cnt+1);
        }
    }
    int main()
    {
        int k,k1,temp;
        cin>>n>>m>>w;
        for(int i=0;i<n;i++)
        {
            cin>>str[i].value;
        }
        while(m--)
        {
        cin>>k>>k1;
        str[k].num1=k1;
        for(int i=0;i<k1;i++)
        {
            cin>>temp;
            str[k].sub[i]=temp;
        }
        }
        a[0]=str[0].value;
        dfs(0,w-str[0].value,1);
        sort(s,s+flag,cmp);
        //cout<<flag<<endl;
        for(int i=0;i<flag;i++)
        {
            for(int j=0;j<s[i].size();j++)
            {
                if(j==0)
                cout<<int(s[i][j]-'0');
                else
                cout<<" "<<int(s[i][j]-'0');
            }
            cout<<endl;
        }
        return 0;
     } 

    总有一些case过不了

    如果你够坚强够勇敢,你就能驾驭他们
  • 相关阅读:
    SpringBoot EnumValidator验证器实现
    【原创】SpringCloud:基于Spring Cloud netflix全家桶搭建一个完整的微服务架构系统
    Hystrix Dashboard监控报“Unable to connect to Command Metric Stream”?
    Mysql sql_mode的合理设置
    nginx 调优
    函数指针
    进程与线程
    大小端学习
    联合体和结构体
    内存分配
  • 原文地址:https://www.cnblogs.com/liuzhaojun/p/11224496.html
Copyright © 2011-2022 走看看