zoukankan      html  css  js  c++  java
  • 1047 Student List for Course

    Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤), the total number of students, and K (≤), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤) which is the number of courses that this student has registered, and then followed by Ccourse numbers. For the sake of simplicity, the courses are numbered from 1 to K.

    Output Specification:

    For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

    Sample Input:

    10 5
    ZOE1 2 4 5
    ANN0 3 5 2 1
    BOB5 5 3 4 2 1 5
    JOE4 1 2
    JAY9 4 1 2 5 4
    FRA8 3 4 2 5
    DON2 2 4 5
    AMY7 1 5
    KAT3 3 5 4 2
    LOR6 4 2 4 1 5
    

    Sample Output:

    1 4
    ANN0
    BOB5
    JAY9
    LOR6
    2 7
    ANN0
    BOB5
    FRA8
    JAY9
    JOE4
    KAT3
    LOR6
    3 1
    BOB5
    4 7
    BOB5
    DON2
    FRA8
    JAY9
    KAT3
    LOR6
    ZOE1
    5 9
    AMY7
    ANN0
    BOB5
    DON2
    FRA8
    JAY9
    KAT3
    LOR6
    ZOE1
    
    /*
        Name:
        Copyright:
        Author:  流照君
        Date: 2019/8/4 17:02:05
        Description:
    */
    #include <iostream>
    #include<string>
    #include <algorithm>
    #include <vector>
    using namespace std;
    const int inf=40040;
    string name[inf];
    vector<int> course[inf];
    int cmp(int a,int b)
    {
        return name[a]<name[b];
    }
    int main(int argc, char** argv)
    {
        //freopen("in.txt", "r", stdin);
        //freopen("out.txt", "w", stdout);
        int n,m,cnt,s;
        cin>>n>>m;
        for(int i=0;i<n;i++)
        {
            cin>>name[i]>>cnt;
            for(int j=0;j<cnt;j++)
            {
                cin>>s;
                course[s].push_back(i);
            }
        }
        for(int i=1;i<=m;i++)
        {
            cout<<i<<" "<<course[i].size()<<endl;
            sort(course[i].begin(),course[i].end(),cmp);
            for(int j=0;j<course[i].size();j++)
            {
                cout<<name[course[i][j]]<<endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    Python自动化开发课堂笔记【Day02】
    Python自动化开发课堂笔记【Day01】
    Python自动化开发课堂笔记【Day01】
    Python自动化开发课堂笔记【Day01】
    SOCKET.IO 前后端使用
    socket.io的emit使用清单
    nodejs 教程
    斗地主滑动选牌&&出牌
    Cocos Creator大厅+子游戏模式
    cocoscreator热更新
  • 原文地址:https://www.cnblogs.com/liuzhaojun/p/11299448.html
Copyright © 2011-2022 走看看