zoukankan      html  css  js  c++  java
  • 1042 Shuffling Machine

    Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

    The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

    S1, S2, ..., S13, 
    H1, H2, ..., H13, 
    C1, C2, ..., C13, 
    D1, D2, ..., D13, 
    J1, J2
    

    where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer K (≤) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    2
    36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
    

    Sample Output:

    S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5


    /*
        Name:
        Copyright:
        Author:  流照君
        Date: 2019/8/7 9:57:15
        Description:
    */
    #include <iostream>
    #include<string>
    #include <algorithm>
    #include <vector>
    #define inf 0x3f3f3f3f
    using namespace std;
    int s[55],s1[55];
    void move(int a,int b)
    {
        s1[b]=s[a];
    }
    void move1(int a,int b)
    {
        s[b]=s1[a];
    }
    int main(int argc, char** argv)
    {
        //freopen("in.txt", "r", stdin);
        //freopen("out.txt", "w", stdout);
        int n,a[55];
        for(int i=1;i<=54;i++)
         s[i]=i;
        cin>>n;
        for(int i=1;i<55;i++)
        cin>>a[i];
        for(int j=1;j<=n;j++)
        for(int i=1;i<55;i++)
        {
            if(j%2==1)
            move(i,a[i]);
            else
            move1(i,a[i]);
        }
        if(n%2==0)
        {
        for(int i=1;i<=53;i++)
        {
            if(s[i]<14)
            {
                cout<<"S"<<s[i]<<" ";
            }
            else if(s[i]<27)
            {
                cout<<"H"<<s[i]-13<<" ";
            }
            else if(s[i]<40)
            {
                cout<<"C"<<s[i]-26<<" ";
            }
            else if(s[i]<53)
            {
                cout<<"D"<<s[i]-39<<" ";
            }
            else
            {
                cout<<"J"<<s[i]-52<<" ";
            }
        }
        if(s[54]<14)
            {
                cout<<"S"<<s[54];
            }
            else if(s[54]<27)
            {
                cout<<"H"<<s[54]-13;
            }
            else if(s[54]<40)
            {
                cout<<"C"<<s[54]-26;
            }
            else if(s[54]<53)
            {
                cout<<"D"<<s[54]-39;
            }
            else
            {
                cout<<"J"<<s[54]-52;
            }
        }
        else if(n%2==1)
        {
        for(int i=1;i<=53;i++)
        {
            if(s1[i]<14)
            {
                cout<<"S"<<s1[i]<<" ";
            }
            else if(s1[i]<27)
            {
                cout<<"H"<<s1[i]-13<<" ";
            }
            else if(s1[i]<40)
            {
                cout<<"C"<<s1[i]-26<<" ";
            }
            else if(s1[i]<53)
            {
                cout<<"D"<<s1[i]-39<<" ";
            }
            else
            {
                cout<<"J"<<s1[i]-52<<" ";
            }
        }
        if(s1[54]<14)
            {
                cout<<"S"<<s1[54];
            }
            else if(s1[54]<27)
            {
                cout<<"H"<<s1[54]-13;
            }
            else if(s1[54]<40)
            {
                cout<<"C"<<s1[54]-26;
            }
            else if(s1[54]<53)
            {
                cout<<"D"<<s1[54]-39;
            }
            else
            {
                cout<<"J"<<s1[54]-52;
            }
        }
        return 0;
    }
  • 相关阅读:
    linux挂载
    kafka
    使用python27+flask
    arcpy 10.8计算最短路径,并复制出结果
    arcgis pro2.5使用试用
    arcgis engine create featureclass , gp工具
    python和c#的 opencv文字区域识别
    C#调用带参数并输出控制台的python的EXE程序
    arcgis10.8中 python27打包exe文件
    arcgis engine指定范围导出屏幕图片
  • 原文地址:https://www.cnblogs.com/liuzhaojun/p/11314486.html
Copyright © 2011-2022 走看看