zoukankan      html  css  js  c++  java
  • 1054 The Dominant Color

    Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N(for example, 8), you are supposed to point out the strictly dominant color.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤) and N (≤) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, simply print the dominant color in a line.

    Sample Input:

    5 3
    0 0 255 16777215 24
    24 24 0 0 24
    24 0 24 24 24
    

    Sample Output:

    24


    /*
        Name:
        Copyright:
        Author:  流照君
        Date: 2019/8/7 14:53:26
        Description:
    */
    #include <iostream>
    #include<string>
    #include <algorithm>
    #include <vector>
    #include<map>
    #define inf 90000000
    using namespace std;
    map<int,int> a;
    int main(int argc, char** argv)
    {
        //freopen("in.txt", "r", stdin);
        //freopen("out.txt", "w", stdout);
        int n,m,temp;
        cin>>n>>m;
        int half=(n*m)/2;
        for(int i=1;i<=n*m;i++)
        {
            cin>>temp;
            a[temp]++;
            if(a[temp]>half)
            {
                cout<<temp<<endl;
                return 0;
            }
        }
        return 0;
    }

    map 的应用

  • 相关阅读:
    理解闭包Closure
    理解商集
    理解格
    理解距(数学)
    微积分英文词汇,高数名词中英文对照,高等数学术语英语翻译一览
    对Extjs中store的多种操作
    mysql中的除法取整
    【python】用asq实现count(distinct cln)
    Timer 和TimerTask的使用
    使用vim.rc配置vim
  • 原文地址:https://www.cnblogs.com/liuzhaojun/p/11315533.html
Copyright © 2011-2022 走看看