zoukankan      html  css  js  c++  java
  • 1071 Speech Patterns stl--map

    People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

    Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

    Input Specification:

    Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return  . The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

    Output Specification:

    For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

    Note that words are case insensitive.

    Sample Input:

    Can1: "Can a can can a can?  It can!"
    

    Sample Output:

    can 5
    
    /*
        Name:
        Copyright:
        Author:  流照君
        Date: 2019/8/21 10:01:28
        Description:
    */
    #include <iostream>
    #include<string>
    #include <algorithm>
    #include <vector>
    #include<map> 
    #define inf 0x3f3f3f3f
    using namespace std;
    typedef long long ll;
    map<string,ll> m;
    string s,s1;
    int main(int argc, char** argv)//柳神就是高啊 
    {
        //freopen("in.txt", "r", stdin);
        //freopen("out.txt", "w", stdout);
    	getline(cin,s);
        for(auto i=0;i<s.length();i++)
        {
        	if(isalnum(s[i]))//判断s[i]是否由大小写字母或数字组成 
        	{
        		s[i]=tolower(s[i]);//转小写 
        		s1=s1+s[i];
    		}
    		if(!isalnum(s[i])||i==s.length()-1)
    		{
    			if(s1.size()!=0)
    			m[s1]++;
    			s1="";
    		}
    	}
    	ll mm=1;
    	//auto it1=m.begin();
    	for(auto it=m.begin();it!=m.end();it++)
    	{
    		if(it->second>mm)
    		{
    			s=it->first;
    			mm=it->second;
    		}
    	}
        cout<<s<<" "<<mm<<endl;
        return 0;
    }
    

      

  • 相关阅读:
    socket详解(二)----实例和多线程,线程池使用
    OpenJDK和JDK区别
    单词(11)
    程序员到项目经理:从内而外的提升(比较全面的介绍)
    如何成为一名自然语言处理工程师
    权限设计文章汇总
    ECharts+百度地图,默认选中 卫星地图
    Echarts3.0 引入百度地图(转载)
    echarts地图 鼠标滚动控制缩放大小比例(转载)
    echarts散点图 不显示问题 或宽度为0问题
  • 原文地址:https://www.cnblogs.com/liuzhaojun/p/11387705.html
Copyright © 2011-2022 走看看