zoukankan      html  css  js  c++  java
  • 算法笔记_093:蓝桥杯练习 Problem S4: Interesting Numbers 加强版(Java)

    目录

    1 问题描述

    2 解决方案

     


    1 问题描述

    Problem Description
      We call a number interesting, if and only if:
      1. Its digits consists of only 0, 1, 2 and 3, and all these digits occurred at least once.
      2. Inside this number, all 0s occur before any 1s, and all 2s occur before any 3s.
      Therefore, the smallest interesting number according to our definition is 2013. There are two more interseting number of 4 digits: 2031 and 2301.
      Your task is to calculate the number of interesting numbers of exactly n digits. As the answer might be very large, you only need to output the answer modulo 1000000007.
    Input Format
      The input has one line consisting of one positive integer n (4 ≤ n ≤ 10^15).
    Output Format
      The output has just one line, containing the number of interesting numbers of exactly n digits, modulo 1000000007.
    Input Sample
      4
    Output Sample
      3

     


    2 解决方案

    本题主要考查数学组合数推理化简,具体思考过程如下:

    引用自文末参考资料1

     

    推导过程,在草稿纸上推导了一下:

    本文下面代码结果运行为90分,代码仅供参考,文末参考资料1中代码运行结果为100分,可以参考一下哦。

    具体代码如下:

    import java.util.Scanner;
    
    public class Main {
        public final static long p = 1000000007L;
        //求取a的b次方取余p的值
        public long getPowMod(long a, long b) {
            long temp = a, result = 1;
            while(b != 0) {
                if((b & 1) == 1)
                    result = result * temp % p;
                temp = temp * temp % p;
                b >>= 1;
            }
            return result;
        }
        
        public void printResult(long n) {
            if(n == 4) {
                System.out.println(3);
                return;
            }
            long m = n - 1;
            long result = getPowMod(2, m - 2);
            m = m % p;
            result = result * (m * m % p - 3 * m % p) % p + m;
            result %= p;
            System.out.println(result);
            return;
        }
        
        public static void main(String[] args) {
            Main test = new Main();
            Scanner in = new Scanner(System.in);
            long n = in.nextLong();
            test.printResult(n);
            
        }
    }

    参考资料:

    1. 算法提高 Problem S4: Interesting Numbers 加强版 解题报告

  • 相关阅读:
    [VBS]遍历XML文档
    [VBS]带参数删除扩展名不是*.h、*.c、*.cpp的全部文件
    [VBS]脚本中的字典、动态数组、队列和堆栈
    [VBS]检测计算机各硬件信息
    [cmd]如何设置 Windows 默认命令行窗口大小和缓冲区大小
    VB.NET and C# 差异
    host-only局域网络
    高并发、死锁、幂等性问题
    elasticsearch简单实现
    记一次504 Gateway Time-out
  • 原文地址:https://www.cnblogs.com/liuzhen1995/p/6575787.html
Copyright © 2011-2022 走看看