zoukankan      html  css  js  c++  java
  • hdu 1055 Color a Tree (树+贪心)

    Color a Tree

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3080    Accepted Submission(s): 1110


    Problem Description
    Bob is very interested in the data structure of a tree. A tree is a directed graph in which a special node is singled out, called the "root" of the tree, and there is a unique path from the root to each of the other nodes. 

    Bob intends to color all the nodes of a tree with a pen. A tree has N nodes, these nodes are numbered 1, 2, ..., N. Suppose coloring a node takes 1 unit of time, and after finishing coloring one node, he is allowed to color another. Additionally, he is allowed to color a node only when its father node has been colored. Obviously, Bob is only allowed to color the root in the first try. 

    Each node has a “coloring cost factor”, Ci. The coloring cost of each node depends both on Ci and the time at which Bob finishes the coloring of this node. At the beginning, the time is set to 0. If the finishing time of coloring node i is Fi, then the coloring cost of node i is Ci * Fi. 

    For example, a tree with five nodes is shown in Figure-1. The coloring cost factors of each node are 1, 2, 1, 2 and 4. Bob can color the tree in the order 1, 3, 5, 2, 4, with the minimum total coloring cost of 33.



    Given a tree and the coloring cost factor of each node, please help Bob to find the minimum possible total coloring cost for coloring all the nodes.
     
    Input
    The input consists of several test cases. The first line of each case contains two integers N and R (1 <= N <= 1000, 1 <= R <= N), where N is the number of nodes in the tree and R is the node number of the root node. The second line contains N integers, the i-th of which is Ci (1 <= Ci <= 500), the coloring cost factor of node i. Each of the next N-1 lines contains two space-separated node numbers V1 and V2, which are the endpoints of an edge in the tree, denoting that V1 is the father node of V2. No edge will be listed twice, and all edges will be listed. 

    A test case of N = 0 and R = 0 indicates the end of input, and should not be processed. 
     
    Output
    For each test case, output a line containing the minimum total coloring cost required for Bob to color all the nodes.
     
    Sample Input
    5 1 1 2 1 2 4 1 2 1 3 2 4 3 5 0 0
     
    Sample Output
    33
     
    贪心
     
    推荐博客:https://blog.csdn.net/gatieme/article/details/49202739
     
    #include<iostream>
    #include<cstdio>
    #include<string.h>
    #define mem(a,b) memset(a,b,sizeof(a))
    using namespace std;
    int n,r;
    struct node{
        double w;//当前到这点的代价 
        int c;//总权值(包括子节点) 
        int t;//时间(也是当前节点的所有节点节点个数(子节点+他自己)) 
        int pre;
    }tree[1010];
    int find_max(){//找最大 的节点,即到先达它能得到最大价值的那个 
        double Max=-1.0;
        int p;
        for(int i=1;i<=n;i++){
            if(Max<tree[i].w&&i!=r){//根节点不参与运算,因为在@处已经算了根结点直接到每个节点的花费 
                Max=tree[i].w;
                p=i;
            }
        }
        return p;
    }
    int main(){
        while(cin>>n>>r&&n+r){
            mem(tree,0);
            int ans=0;
            for(int i=1;i<=n;i++){
                cin>>tree[i].c;
                tree[i].w=tree[i].c;
                tree[i].t=1;
                ans+=tree[i].c;//先计算从根节点直接到达每个节点的值 
            }
            for(int i=1;i<n;i++){
                int a,b;
                cin>>a>>b;
                tree[b].pre=a;
            }
            for(int i=1;i<n;i++){
                int Max=find_max();
                int p=tree[Max].pre;
                tree[Max].w=0;//计算过将他赋值为0,以便后面的计算 
                ans+=tree[Max].c*tree[p].t;//从 Max的父节点到它所要的价值 
            //    cout<<Max<<"->"<<tree[Max].c<<"      "<<p<<"    "<<tree[p].t<<endl; 
                for(int i=1;i<=n;i++){
                    if(tree[i].pre==Max){
                        tree[i].pre=p;//将原本Max的子节点改成p(即Max的父节点) 的子节点 
                    }
                }
                tree[p].t+=tree[Max].t;//累加总时间 
                tree[p].c+=tree[Max].c;//累加总价值 
                tree[p].w=1.0*tree[p].c/tree[p].t;//!!!这里的当前价值是到达该点后所能得到的价值(平均值),这是贪心的核心 
            }
            cout<<ans<<endl;
        }
        return 0; 
    }
  • 相关阅读:
    如何让pc端网站在手机上可以等比缩放的整个显示
    CSS
    常见的IE布局兼容问题
    CSS : 使用 z-index 的前提
    CSS : object-fit 和 object-position实现 图片或视频自适应
    CSS
    vscode
    如何识别Form字段中一对多或者多对多字段
    window.open简单使用
    由一个模型拿它的名字、app的名字、字段对象以及字段对象中的属性
  • 原文地址:https://www.cnblogs.com/liuzuolin/p/10505473.html
Copyright © 2011-2022 走看看