zoukankan      html  css  js  c++  java
  • HDU 4771 Stealing Harry Potter's Precious

    Stealing Harry Potter's Precious

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)



    Problem Description
      Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:



      Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.
     
    Input
      There are several test cases.
      In each test cases:
      The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).
      Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.
      The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.
      In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).
      The input ends with N = 0 and M = 0
     
    Output
      For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.
     
    Sample Input
    2 3
    ##@
    #.#
    1
    2  2
    4 4
    #@##
    ....
    ####
    ....
    2
    2 1
    2 4
    0 0
     
    Sample Output
    -1
    5
               也是暴力的思想吧!
     
    #include <iostream>
    #include <stdio.h>
    #include <string>
    #include <string.h>
    #include <math.h>
    #include <algorithm>
    #include <vector>
    #include <queue>
    #include <set>
    #define Min(a ,b )  ((a)<(b)?(a):(b))
    using namespace std;
    const int Max_N=108 ;
    const int inf=1000000000 ;
    int  N , M ,K ;
    char str[Max_N][Max_N]  ;
    int d[4][2]={ {1,0}, {0,1}  ,{-1 ,0} ,{0 ,-1} } ;
    
    int cango(int x ,int  y){
        return 1<=x&&x<=N&&1<=y&&y<=M  ;
    }
    
    struct  Node{
          int X  ;
          int Y  ;
          int step  ;
          Node(){} ;
          Node(int x  ,int y ,int s):X(x),Y(y),step(s){} ;
          friend bool operator <(const Node A ,const Node B){
                  return A.step>B.step  ;
          }
    } ;
    
    int  dist[Max_N] [Max_N] ;
    
    void spfa(int x ,int y ){
          priority_queue<Node>que  ;
          que.push(Node(x,y,0))  ;
          for(int i=1 ; i<=N ; i++)
             for(int j=1 ; j<=M ;  j++)
                  dist[i][j]=inf ;
          dist[x][y]=0  ;
          while(!que.empty() ){
                Node now = que.top()   ;
                que.pop()  ;
                for(int i=0 ; i<4 ; i++){
                       int x=now.X + d[i][0] ;
                       int y=now.Y + d[i][1] ;
                       if(!cango(x,y))
                             continue  ;
                       if(str[x][y] != '.')
                             continue  ;
                       if( now.step+1<dist[x][y] ){
                             dist[x][y] = now.step + 1  ;
                             que.push( Node(x,y,dist[x][y]) )   ;
                       }
                }
          }
    }
    
    struct   Point {
          int X  ;
          int Y  ;
    } ;
    
    Point p[8] ;
    int grid[8][8] ;
    int sele[8]  ;
    bool use[8]  ;
    int ans ;
    
    void dfs(int id){
        if(id>K){
                int sum = 0 ;
                for(int i = 1 ; i <= K ; i++)
                       sum+=grid[ sele[i-1] ][ sele[i] ]  ;
                 ans=Min(ans,sum) ;
        }
        for(int i = 1 ; i <= K ; i++ ){
             if(use[i]){
                  sele[id] = i  ;
                  use[i]=0 ;
                  dfs(id+1)  ;
                  use[i] = 1 ;
             }
        }
    }
    
    int main() {
        while(cin>>N>>M){
              if(N==0&&M==0)
                   break  ;
              for(int i=1 ; i<=N ; i++)
                        scanf("%s",str[i]+1)  ;
              for(int i=1 ; i<=N ; i++)
                  for(int j=1 ; j<=M ; j++){
                        if(str[i][j]=='@'){
                                p[0].X = i ;
                                p[0].Y = j ;
                                str[i][j] = '.'  ;
                         }
               }
               cin>>K ;
               for(int i = 1 ; i<=K ; i++)
                      scanf("%d%d",&p[i].X,&p[i].Y)  ;
               for(int i = 0 ; i <= K  ;  i++){
                      spfa(p[i].X , p[i].Y )  ;
                      for(int j = 0  ; j <= K ; j++){
                              grid[i][j] = dist[ p[j].X ][ p[j].Y ]  ;
                      }
               }
               memset(use,1,sizeof(use))  ;
               sele[0]=0 ;
               ans=inf  ;
               dfs(1) ;
               if(ans==inf)
                   puts("-1")  ;
               else
                   cout<<ans<<endl  ;
        }
        return 0;
    }
  • 相关阅读:
    微信开发 之 开启开发模式
    微信公众号开发 之 编辑模式使用
    分析各种Android设备屏幕分辨率与适配
    【面向对象设计模式】 适配器模式 (二)
    重构 之 总结代码的坏味道 Bad Smell (一) 重复代码 过长函数 过大的类 过长参数列 发散式变化 霰弹式修改
    【Android 应用开发】Android资源文件
    java 创建并写入文件
    隐藏 HttpClient 在console的日志
    HOW TO CHANGE THE DEFAULT KEY-VALUE SEPARATOR OF A MAPREDUCE JOB
    java 时间戳转换
  • 原文地址:https://www.cnblogs.com/liyangtianmen/p/3416048.html
Copyright © 2011-2022 走看看