zoukankan      html  css  js  c++  java
  • hdu 1247 (字典树入门)

    Hat’s Words

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 12149    Accepted Submission(s): 4338


    Problem Description
    A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
    You are to find all the hat’s words in a dictionary.
     
    Input
    Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
    Only one case.
     
    Output
    Your output should contain all the hat’s words, one per line, in alphabetical order.
     
    Sample Input
    a ahat hat hatword hziee word
     
    Sample Output
    ahat hatword
    题意:找出能有已知给定两个单词组成的单词。
    思路:先插入每个单词进入字典树,然后分别对每个单词进行查找,find找到前缀后再利用find2找到后缀,当后缀对应某个单词时,则证明此单词由两个字典中单词组成
    注意输入到文件尾
    package 字典树;
    
    import java.util.Scanner;
    
    class Trie{
        private Node root;
        public Trie() {
            root = new Node();
        }
        public void insert(String s){
            Node t =root;
            for(int i=0;i<s.length();i++){
                if(t.nodes[s.charAt(i)-'a']==null){
                    Node node = new Node();
                    t.nodes[s.charAt(i)-'a'] = node;
                }
                t = t.nodes[s.charAt(i)-'a'];
            }
            t.isword = true;
        }
        public boolean find(String str){
            Node t = root;
            for(int i=0;i<str.length();i++){
                if(t.nodes[str.charAt(i)-'a']!=null){
                    if(t.isword){
                        String str1 = str.substring(i, str.length());
                        //System.out.println(str1);
                        if(find2(str1)){
                            return true;
                        }
                    }
                    t = t.nodes[str.charAt(i)-'a'];
                }
                else return false;
            }
            return false;
        }
        private boolean find2(String str) {
            Node t = root;
            for(int i=0;i<str.length();i++){
                if(t.nodes[str.charAt(i)-'a']==null){
                    return false;
                }
                t = t.nodes[str.charAt(i)-'a'];
            }
            if(t.isword) return true;
            return false;
        }
        public 
        class Node {
            Node [] nodes;
            boolean isword;  //标记末尾
            public Node() {
                isword = false;
                nodes = new Node[26];
            }
        }
    }
    public class hdu_1247 {
        public static void main(String[] args) {
            Scanner sc =new Scanner(System.in);
            Trie t = new Trie();
            String [] str  = new String [50005];
            int k=0;
             
            while(sc.hasNext())
            {
                str[k] = new String();
                str[k] = sc.next();
                t.insert(str[k++]);
            }
            for(int i=0;i<k;i++){
                if(t.find(str[i])){
                    System.out.println(str[i]);
                }
            }
        }
    }
  • 相关阅读:
    顺时针打印二维矩阵
    hbase的rowKey设计原则
    关于这段时间学习 EntityFramework的 一点感悟
    一次排序序号的补充
    我的第一段jQuery代码
    非常郁闷的 .NET中程序集的动态加载
    关于EF6的记录Sql语句 与 EntityFramework.Extend 的诟病
    排序更改
    ZhyjEye 简介
    js数组去重的4个方法
  • 原文地址:https://www.cnblogs.com/liyinggang/p/5303032.html
Copyright © 2011-2022 走看看