zoukankan      html  css  js  c++  java
  • [ACM] ZOJ 3819 Average Score (水题)

    Average Score

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.

    After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

    "Too bad! You made me so disappointed."

    "Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

    Now, you are given the scores of all students in the two classes, except for the Bob's. Please calculate the possible range of Bob's score. All scores shall be integers within [0, 100].

    Input

    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob's class and the number of students in the other class respectively.

    The next line contains N - 1 integers A1A2, .., AN-1 representing the scores of other students in Bob's class.

    The last line contains M integers B1B2, .., BM representing the scores of students in the other class.

    Output

    For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.

    It is guaranteed that the solution always exists.

    Sample Input

    2
    4 3
    5 5 5
    4 4 3
    6 5
    5 5 4 5 3
    1 3 2 2 1
    

    Sample Output

    4 4
    2 4
    

    Author: JIANG, Kai
    Source: The 2014 ACM-ICPC Asia Mudanjiang Regional Contest


    解题思路:

    题意为 bob所在的班有n个人,每人都有一个成绩,另外一个班有m个人。没人都有一个成绩,假设把bob放到还有一个班里去。那么两班的平均分都比原来的班内平均分要高,问符合条件的bob的成绩的范围。

    枚举就可以。

    代码:

    #include <iostream>
    #include <cmath>
    using namespace std;
    int t;
    double a[52];
    double b[52];
    int n,m;
    int bob;
    int s,e;
    
    int main()
    {
        cin>>t;
        while(t--)
        {
            cin>>n>>m;
            double sum1=0.0;
            double sum2=0.0;
            double pre1,pre2;
            for(int i=1;i<=n-1;i++)
            {
                cin>>a[i];
                sum1+=a[i];
            }
            for(int i=1;i<=m;i++)
            {
                cin>>b[i];
                sum2+=b[i];
            }
            bool first=0;
            for(bob =0;bob<=100;bob++)
            {
                pre1=(sum1+bob)/n;
                pre2=(sum2)/m;
                if((sum1)/(n-1)>pre1&&(sum2+bob)/(m+1)>pre2)
                {
                    if(first)
                        e=bob;
                    if(!first)
                    {
                        s=bob;
                        e=bob;
                    }
                    first=1;
                }
    
            }
            cout<<s<<" "<<e<<endl;
        }
        return 0;
    }


  • 相关阅读:
    随机100道四则运算(文件储存)
    基于 GitBook 搭建个人博客
    ios常用第三方库git下载地址
    网络工程师经常会用到的终端仿真软件
    最常用的终端仿真程序 替代putty
    Linux 命令大全
    Nginx 安装配置
    nginx
    React函数组件和class组件以及Hook
    2020年前端面试题及答案
  • 原文地址:https://www.cnblogs.com/llguanli/p/6932734.html
Copyright © 2011-2022 走看看