zoukankan      html  css  js  c++  java
  • hdu 1075 What Are You Talking About(map)

    What Are You Talking About

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
    Total Submission(s): 16042    Accepted Submission(s): 5198


    Problem Description
    Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
     

    Input
    The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab(' '), enter(' ') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
     

    Output
    In this problem, you have to output the translation of the history book.
     

    Sample Input
    START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
     

    Sample Output
    hello, i'm from mars. i like earth!
    Hint
    Huge input, scanf is recommended.
     

    Author
    Ignatius.L
     

    Recommend
    We have carefully selected several similar problems for you:  1800 1671 1298 1026 1016 

     

    直接map.

    #include<cstring>
    #include<cstdio>
    #include<iostream>
    #include<map>
    #include<string>
    
    
    using namespace std;
    
    int main() {
        //freopen("test.in","r",stdin);
        string a,b;
        map<string,string>mp;
        while(1) {
            cin>>a;
            if(a=="START")continue;
            if(a=="END")break;
            cin>>b;
            mp[b]=a;
        }
        char s[1010];
        getchar();
        while(1) {
            gets(s);
            if(strcmp(s,"START")==0)continue;
            if(strcmp(s,"END")==0)break;
            int len=strlen(s);
            char p[40];
            int l=0;
            map<string,string>::iterator it;
            for(int i=0; i<len; i++) {
                if(s[i]<'a'||s[i]>'z') {
                    if(l!=0) {
                        p[l]='';
                        if(mp[p]!="")
                             cout<<mp[p];
                        else
                            printf("%s",p);
                    }
                    printf("%c",s[i]);
                    l=0;
                } else {
                    p[l++]=s[i];
                }
            }
            cout<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    根据指定的编码格式返回请求的参数集合
    【C++ 学习笔记】 size_t 和 int
    C++ 编译错误
    【Flex】 加载Gif文件
    【C++ 学习笔记】:STLmap
    【C++ 学习笔记】:MFC(细节部分)
    小卡的土豆园开园了~
    [论文笔记] A novel reduction approach to analyzing QoS of workflow processes (Concurrency and Computation: Practice and Experience, 2009)
    [论文收集] WWW2008 相关或感兴趣的论文
    [论文泛读] Accurate and efficient stochastic reliability analysis of composite services using their compact Markov reward model representations (SCC, 2007)
  • 原文地址:https://www.cnblogs.com/llguanli/p/8426189.html
Copyright © 2011-2022 走看看