zoukankan      html  css  js  c++  java
  • hdu-1179-二分图最大匹配

    Ollivanders: Makers of Fine Wands since 382 BC.

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
    Total Submission(s): 1585    Accepted Submission(s): 878


    Problem Description
    In Diagon Alley ,there is only one Wand-seller,peeling gold letters over the door read Ollivanders: Makers of Fine Wands since 382 BC.A single wand lay on a faded purple cushion in the dusty window. 
    A tinkling bell rang somewhere in the depths of the shop as they stepped inside.It was a tiny place,empty execpt for a single spindly chair which Hagrid sat on to wait.Harry felt strangely as though he had entered a very strict library;he swallowd a log of new questions which had just occurred to him and looked instead at the thousands of narrow boxes piled neatly right up to the ceiling.For some reason,the back of his neck prickled.The very dust and silence in here seemed to tingle with some secret magic. 
    'Good afternoon,'said a soft voice.Harry jumped.Hagrid must have jumped,too,because there was a loud crunching noise and he got quickly off the spindly chair. 
    An old man was standing before them, his wide pale eyes shining like moons through the gloom of the shop. 
    'Hello,' said Harry awkwardly. 
    'Ah yes,' said the man. 'Yes,yes. I thought I'd be seeing you soon,Harry Potter.'It wasn't a question.You have your mother's eyes. It seems only yesterday she was in here herself,buying her first wand. Ten and a quarter inches long, swishy, made of willow. Nice wand for charm work.' 
    Mor Ollivander moved closer to Harry.Harry wished he would blink.Those sivery eyes were a bit creepy. 
    'Your father, on the other hand, favoured a mahogany wand.Eleven inches.Pliable.A little more power and excellent for transfiguration.Well ,I say your father favoured it - it's really the wand that choosed the wizard, of cource.' 

    Yes, some wands fit some wizards ,as we all know.But what Harry doesn't know is Ollivander have met a big trouble.That's more than twenty years ago,When Harry's father James Potter was still a student in Hogwarts.He went Diagon Alley to buy new books,passing by Ollivander's shop.Ollivander was crazy for a problem:He was too busy to choose most suitable wand for every wizard.Even more,there are too many customer that day.Though Ollivader knew every wand's favourite,he could not choose as many wizards as possible to get the wands. So James Potter,a very clever man ,gave him a magic disk with your program ,to help him sell wands as many as possible. 

    Please notice: one wand can only be sold to one wizard, and one wizard can only buy one wand,too. 
     
    Input
    There are several cases. For each case, there is two integers N and M in the first line,which mean there is N wizards and M wands(0 < N <= M <= 100).
    Then M lines contain the choices of each wand.The first integer in i+1th line is Ki,and after these there are Ki integers Bi,j which are the wizards who fit that wand. (0<=Ki<=N,1<=Bi,j<=N)
     
    Output
    Only one integer,shows how many wands Ollivander can sell.
     
    Sample Input
    3 4
    3 1
    2 3
    1 1
    1 1
    0
     
    Sample Output
    2
    Hint
    Hint
    Wand 1 fits everyone, Wand 2,3 only fit the first wizard,and Wand 4 does not fit anyone.So Ollivanders can sell two wands: sell Wand 1 to Wizard 2 and Wand 2 to Wizard 1,or sell Wand 1 to Wizard 3 and Wand 3 to Wizard 1 ,or some other cases. But he cannot sell 3 wands because no 3 wands just fit 3 wizards.
     
    题目大意:一个wand匹配一个wizard,问最大匹配
     
    代码:
    #include <iostream>
    #include <vector>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    int link[102],vis[102];
    vector<int>mp[102];
    int n,m;
    int dfs(int x)
    {
        for(int i=0;i<mp[x].size();i++)
        {
            int v=mp[x][i];
            if(!vis[v])
            {
                vis[v]=1;
                if(link[v]==-1||dfs(link[v]))
                {
                    link[v]=x;
                    return 1;
                }
            }
        }
        return 0;
    }
    int main()
    {
        while(cin>>n>>m)
        {
            for(int i=1;i<=m;i++)
            if(mp[i].size())
            mp[i].clear();
            int q,a;
            for(int i=1;i<=m;i++)
            {
                scanf("%d",&q);
                while(q--)
                {   scanf("%d",&a);
                    mp[i].push_back(a);
                }
            }
            int res=0;
            memset(link,-1,sizeof(link));
            for(int i=1;i<=n;i++)
            {
                memset(vis,0,sizeof(vis));
                if(dfs(i))
                res++;
            }
            cout<<res<<endl;
    
        }
    }
  • 相关阅读:
    Linux_MMU
    Linux_CPU寄存器简介
    Linux_数据段、代码段、堆栈段、BSS段的区别
    Linux_基本使用方法
    Linux_代码段和数据段的定义以及思考
    Linux_虚拟地址、线性地址和物理地址的转换
    Linux_微内核和单内核
    Linux_Linux的分段和分页机制
    教你实现一个朴实的Canvas时钟效果
    OpenMetric与时序数据库模型之主流TSDB分析
  • 原文地址:https://www.cnblogs.com/llsq/p/5914059.html
Copyright © 2011-2022 走看看