zoukankan      html  css  js  c++  java
  • 基础-DP

    Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
    The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

    Input

    The first line contain a integer T , the number of cases. 
    Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

    Output

    One integer per line representing the maximum of the total value (this number will be less than 2 31).

    Sample Input

    1
    5 10
    1 2 3 4 5
    5 4 3 2 1

    Sample Output

    14
    #include<iostream>  
    using namespace std;   
    #include<math.h>
    #include<string.h>  
    #define maxn 100000  
    long long d[maxn+5];  
    int max(int a,int b)  
    {  
        if(a>b)
            return a;  
        else 
            return b;  
    }  
    int main()  
    {  
        int t,n,m,i,j;
        int V[1005],N[1005];  
        cin>>t;  
        while(t--)  
        {
            memset(d,0,sizeof(d));  
            cin>>n>>m;  
            for(i=0;i<n;i++)  
                cin>>V[i];  
            for(j=0;j<n;j++)  
                cin>>N[j];  
            for(i=0;i<n;i++)  
                for(j=m;j>=N[i];j--)  
            {  
                d[j]=max(d[j],d[j-N[i]]+V[i]);
            }  
            cout<<d[m]<<endl;  
        }  
        return 0;  
    }  
  • 相关阅读:
    基本数据类型
    概率—基础基本概念
    3.21上午
    3.10下午
    贪心算法回顾
    学习wait、notify和synchronized及Lock
    使用Files更优雅的对文件操作
    Linux下常用命令整理
    Unix下日志操作、访问GET请求
    操作Unix下docker中的redis
  • 原文地址:https://www.cnblogs.com/lsb666/p/5746961.html
Copyright © 2011-2022 走看看