zoukankan      html  css  js  c++  java
  • 数学--数论--HDU 1299 +POJ 2917 Diophantus of Alexandria (因子个数函数+公式推导)

    Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat’s last theorem) was found only recently by Andrew Wiles.

    Consider the following diophantine equation:

    1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)

    Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions:

    1 / 5 + 1 / 20 = 1 / 4
    1 / 6 + 1 / 12 = 1 / 4
    1 / 8 + 1 / 8 = 1 / 4

    Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?
    Input
    The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9).
    Output
    The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line.
    Sample Input
    2
    4
    1260
    Sample Output
    Scenario #1:
    3

    Scenario #2:
    113
    在这里插入图片描述

    #include <bits/stdc++.h>
    using namespace std;
    const int MAX = 5e5 + 5;
    int  n;
    long long ans;
    void solve()
    {
        for (int i = 2; i * i <= n; i++)
        {
            int cnt = 0;
            if (n % i == 0)
            {
                while (n % i == 0)
                {
                    cnt++;
                    n /= i;
                }
            }
            if (cnt)
                ans *= (long long)(2 * cnt + 1);
        }
    }
    
    int main()
    {
        int T;
        scanf("%d", &T);
        for (int ca = 1; ca <= T; ca++)
        {
            ans = 1;
            scanf("%d", &n);
            solve();
            if (n > 1)
                ans *= 3LL;
            printf("Scenario #%d:
    %lld
    
    ", ca, (ans + 1)/2);
            //这里是说题目中x,y y,x相等,应该除2向上取整
        }
    }
    
    
  • 相关阅读:
    mac上finalShell的安装
    c 字符串与字符串操作
    .net5 MailKit
    c 99乘法表
    element 动态表单加自定义校验
    遇到的问题 vscode 问题
    vue-element-admin eslint 规则查询表
    利用html2canvas 导出网页 (只是用于自己的笔记,如果需要看配置,自行查找插件api)
    git 常用命令
    uniapp中自动打包微信小程序后自动上传代码
  • 原文地址:https://www.cnblogs.com/lunatic-talent/p/12798480.html
Copyright © 2011-2022 走看看