Can you solve this equation?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29378 Accepted Submission(s): 12331
Problem Description
Now,given the equation 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
Sample Output
1.6152
No solution!
Author
Redow
Recommendlcy
二分水题,多看看就能理解。
#include<iostream>
#include<algorithm>
#include<vector>
#include<cmath>
#include<iomanip>
using namespace std;
double ys(double e)
{
return 8*pow(e,4)+7*pow(e,3)+2*pow(e,2)+3*e+6;
}
int judge(double u)
{
double v;
v=8*pow(100,4)+7*pow(100,3)+2*pow(100,2)+3*100+6;
if(v>=u&&u>=6)
return true;
return false;
}
int main()
{
int T;
double n,left,right,node;
cin>>T;
while(T--)
{
cin>>n;
if(!judge(n))
cout<<"No solution!"<<endl;
else
{
left=0;right=100;
while(right-left>0.000001)
{
node=(left+right)/2;
if(ys(node)>n)
right=node;
else
left=node;
}
cout<<fixed<<setprecision(4)<<node<<endl;
}
}
}