zoukankan      html  css  js  c++  java
  • ZOJ 3623 Battle Ships

    Battle Ships
    Time Limit: 2 Seconds Memory Limit: 65536 KB
    Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

    Your job is to find out the minimum time the player should spend to win the game.

    Input
    There are multiple test cases.
    The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤ t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

    Output
    Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

    Sample Input
    1 1
    1 1
    2 10
    1 1
    2 5
    3 100
    1 10
    3 20
    10 100

    Sample Output
    2
    4
    5

    #include <cstdio>
    #include <iostream>
    #include <cstring>
    #include <algorithm>
    #include <vector>
    #include <cstdlib>
    using namespace std;
    #define mem(a,b) memset((a),(b),sizeof(a));
    	
    	int dp[350];
    	struct bat{
    		int t;
    		int l;
    	}a[35];
    
    
    int main(){
    	int n,L,mint;
    	while(cin>>n>>L){
    		mem(a,0);
    		mem(dp,0);
    	
    		for(int i=1;i<=n;i++)
    			{
    			cin>>a[i].t>>a[i].l;
    			
    	}	
    		mint=999999999;
    		for(int i=0;i<=L;i++)
    			for(int j=1;j<=n;j++)
    				{
    				dp[i+a[j].t]=max(dp[i],dp[i]+a[j].l*(i));
    				if(dp[i+a[j].t]>=L)
    					mint=min(mint,i+a[j].t); 
    	}
    	
    	cout<<mint<<endl;			
    }
    	
    	
        return 0;}
    
  • 相关阅读:
    Java 面向对象_继承
    Java 面向对象
    使用 pykafka 进行消费
    oracle 的分页、截断查询
    Day03
    Day02 计算机的组成与编程语言
    Day01 MarkDown的使用
    Java方法的重点
    Scanner的小细节
    Java包机制和Javadoc的使用
  • 原文地址:https://www.cnblogs.com/lunatic-talent/p/12798991.html
Copyright © 2011-2022 走看看