zoukankan      html  css  js  c++  java
  • HDU Problem D [ Humble number ]——基础DP丑数序列

    Problem D
    Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 7 Accepted Submission(s) : 3
    Problem Description
    A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

    Write a program to find and print the nth element in this sequence

    Input
    The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

    Output
    For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.

    Sample Input
    1 2 3 4 11 12 13 21 22 23 100 1000 5842 0

    Sample Output
    The 1st humble number is 1.
    The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.

    #include<iostream>
    #include<queue>
    #include<set>
    #include<cstdio>
    using namespace std;
    set<long long int>a;
    vector<long long int>c;
    void js()
    {
        a.insert(1);
        a.insert(2);
        a.insert(3);
        a.insert(4);
        a.insert(5);
        a.insert(6);
        a.insert(7);
        set<long long int>::iterator poi;
        for(poi=a.begin();;poi++)
        {
            a.insert(2**poi);
            a.insert(3**poi);
            a.insert(5**poi);
            a.insert(7**poi);
            if(a.size()>6800)break;
        }
        for(poi=a.begin();poi!=a.end();poi++)
        {
            c.push_back(*poi);
        }
    }
    string fuhao(int a)
    {
        if(a%100==11) return "th";
        else if(a%100==12) return "th";
        else if(a%100==13) return "th";
        else if(a%10==1) return "st";
        else if(a%10==2) return "nd";
        else if(a%10==3) return "rd";
        else return "th";
    }
    int main()
    {
        js();
        int  N;
        while(scanf("%d",&N)&&N)
        cout<<"The "<<N<<fuhao(N)<<" humble number is "<<c[N-1]<<'.'<<endl;
    }
    
  • 相关阅读:
    一个纠结的问题
    打开SQL Developer时,提示缺少快捷方式
    打开eclipse时,An error has occurred. See the log file
    bash: id : command not found
    Fatal error: Call to undefined function: mysql_connect()解决方法
    struts.xml中标签自动提示问题
    Hibernate向Oracle中添加自增字段
    linux 忘记root密码的解决办法
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock'
    Ctrl+Alt+Fn不能切换到字符界面
  • 原文地址:https://www.cnblogs.com/lunatic-talent/p/12799050.html
Copyright © 2011-2022 走看看